Any way to stop lighting from bleeding and going through meshes?

I have a house and a day/night cycle, and i noticed that the lighting goes right through my meshes and into my building, it’s as if there were no walls. I have a directional light set up and the day/night cycle system uses it as the sun.

Take a look at this and see if it helps with your issues
Lighting Troubleshooting Guide

For an animated light make sure that you have surfaces blocking the light since by default a surface is only facing one direction. Also, for the light you can adjust the shadow bias setting which will make shadows tighter to the object that casts it although it can introduce artifacts.