Any way to adjust Navmesh bounds volume, it's doing a poor job?

The terrain in my game is generated in a blueprint and there are a lot of tree meshes which all are Hierarchical instances. The collisions on each mesh are pretty tight to the mesh itself but when the navmesh bounds volume is generated it gives all the trees a wide birth. This leaves very spotty coverage in my map and the AI will not be able to get around at all (see the image below).

Is there any way for me to adjust the navmesh, or is there something else I should do to my tree meshes?

There are many options in the project settings:

1 Like

That is kind of handy sort of but still didn’t fix anything.

The documentation on this is extremely poor in my opinion, from running trial and error the only one that almost helped until it didn’t was lowering the cell size but for some reason lowering it too much makes it even worse.

I don’t get why it still stays so far away from my tree meshes.

What does it look like now?

Well it looks like quitting out of Unreal and reopening fixed it. Strange because I could see the NavMesh updating in realtime as I was playing around changing the settings, then I rage quit out, but whenever I opened it today it’s all working quite well.
Thanks friend!

1 Like