Download

Anti Aliasing not working on Oculus Quest

Hello all,

We are working on porting a test level of a project to the Oculus Quest and while we have gotten things to run smoothly the anti aliasing still does not seem to be working reguardless of the settings.

The edges on everything in the scene are still jagged and flickering. I’ve seen others post about this in the Oculus forums but have not found an answer yet.

Has anyone else run into this?

Hello,
Same problem here. The support indicated me that MSAA4X was forced on the Quest. Not sure if it’s really enabled but everything is aliased in the HMD.

Sounds like opposite problems to me! :smiley:

Stuck on for me too - I’m keen to get to the bottom of this.

Anti-Anti Aliasing pitchforkmobragechant is “Every Pixel Sacred!” :mad:

Edit: Update - I think I was just seeing the difference in pentile vs stripe pixel layout.

In the Oculus plugin MSAA 4x is hardcoded. (Even when choosing other forms of AA)

Have you plans to make it selectable for the 4.23?

is this fixed now? what works, what doesn’t?

same here!

Same here. But I noticed that my OQ2 is set with a resolution above the 1920 per eye. Could it be a lead?

The AA level is now selectable with the latest version of the Oculus plugin which is only available in the Oculus 4.26 branch of unreal:

https://developer.oculus.com/downloads/package/unreal-engine-4-integration/25.0.0/

The amount of MSAA subsampling can now be changed by way of the standard Unreal Engine settings. Previously, MSAA subsampling was hardcoded to 4x.

If you’re referring to the AA on widget then you should be using stereo layers to display your widget to fix those jagged lines :wink:

1 Like