Anti-Aliasing/Blurring problem after deleting default content from the Content Browser...?

I’m not sure exactly what happened or how but the result can be seen in the attached screenshot, where the left side is an example of what my sprites look like now and the right side is what it looked like before. As you can see, the right side is crisp and unaffected by AA or any kind of blurring, whereas the left side is blurred presumably due to some kind of AA being applied.

I didn’t change any AA settings, and after it happened I made sure the Post-Process Volume was set to None for AA and Unbounded was checked.

What happened was, IIRC:

  • I was trying to implement a beam particle system.
  • Somehow I remember DefaultMaterial being opened in some way by accident, possibly when I was looking at the texture of the particle system.
  • I noticed at some point that my Content Browser had several folders of Default content added for some reason, which was annoying but I was possibly going to just leave it if it seemed not to cause a problem until…
  • I tried closing Unreal Editor and I believe it said something about saving changes to DefaultMaterial or canceling etc. I pressed save and it proceeded to take what seemed like it was going to be ages to go through all of this content that I didn’t previously have in my project which didn’t seem right so I think I closed Unreal via Task Manager.
  • Later, I deleted the folders from the Content Browser, figuring that they weren’t there before so it shouldn’t do any harm…
  • When I opened my project back up, sprites looked blurry when I hit Play despite looking fine in the editor and there being a Post-Process Volume set to not use AA.

Is there some way of setting things back to default that would probably fix this? It’s quite strange and I’m out of ideas beyond starting a new project and copying everything over, which might be unnecessary hassle and there’s no telling if this might happen again…

To add a bit more detail… I often get a strange pink artifact on my icons. The sprites in the content browser even look corrupted until I open them and then they go back to normal there. I’ve included a screenshot of this in case it might provide a clue as to what’s happening.

I tried creating a new project and migrating the content over, but the same thing still happens. I have an older version of the project too where this problem isn’t happening and migrating the sprites/textures from that doesn’t help either.

The only difference that seems to leave between them is that the old version is using 4.9.2 and the others are on 4.10.1. Maybe that has something to do with it, like I corrupted something. I’ll try using the Verify option and see if that fixes it…

Nope, nothing. Maybe I should try reinstalling completely. Any other ideas?

Whoops, I didn’t add the screenshots properly… fixed now.

Ok, I reinstalled Unreal 4.10.1 and that didn’t make a difference. Not sure if I have any more ideas… everything seems identical between the old version that displays the pixels correctly and the newer versions with the horrible blurring…

Actually, is there some way of rolling back changes in Unreal? What is the Backup folder of a project for? I notice that inside that, there just happens to be 2 DefaultMaterial files that just happen to contain the same date as I made this topic… so I’m assuming that suggests something was changed on that day. I remember something about DefaultMaterial, so I’m wondering if there’s a connection.