ANSEL session can't be activated at the moment [SOLVED]

Quick fix for the ANSEL problem.
Sometimes photography is not allowed at gameplay.

Nice! I had the same problem. :slight_smile:

I still can’t resolve my problem at UE4.23. My Nvidia Experience version is, I deactivated the experimental resources from it, i did the cmd code “C:\Program Files\NVIDIA Corporation\Ansel\NvCameraEnable.exe” whitelisting-everything (but it open the exe file rather than apply the whitelist) and my video card is from Nvidia. What am I doing wrong???

One thing that worked for me was Validating my UE4 version, and then applying those steps from the video…

Hi Bathil! What do you mean by Validating? Yesterday i got this working just installing an older version from Nvidia Experience ( Problem is I can’t expect people will do this in order to use it in my game, neither to say once my computer restarts the Nvidia Experience updates to the latest version automatically. I really would like to have this working in latest versions. Some people said to me that i need to update Ansel plugin at Engine folder…but i have no clue what i need to do there (I know a bit of C++ workflow).

This is outrageous. UE4 should have all these ANSEL features built into a capture/export system. Unbelievable…

Worked like a charm. Thanks a lot!

Tried this but cant seem to get Ansel linked in the “is photography allowed” node.

my node seems to be different from the one in the video or did you edit your’s in anyway?

Hi everyone,

In my case Ansel is not working on UE4.25 (and 4.26 preview) with Geforce Experience
I had to downgrade to Geforce Experience previous versions like
I am encountering the same situation as described here when using v3.20.4.14
I checked that plugin is activated and allowPhotography set to true (like here UE4 - Ansel Can't be activated [ SOLVED ] - YouTube), but nothing was working until downgrade.
so I don’t have any explantation

But after 2-3 screenshots working, Ansel was not working anymore with v3.18.0.102
Alt f2 and Alt f3 are doing same errors while Alt f9 is working.
Any idea to fix this problem ?

(issue also posted here :


If you can’t link the “is photography allowed” node than make sure you have the ansel plugin enabled in the current project.