Download

Another Texture Streaming Post

Hi Everyone,

Hoping someone can help me out, I’ve searched through multiple posts here and online and the official documentation here https://docs.unrealengine.com/latest/INT/Engine/Content/Types/Textures/Streaming/ but can’t find an answer that works for me. I’m using 4.16 but I’ve have problems like this on almost every build even in previous versions. I asked my local UE4 community and no-one encounters these issues so wondering if it’s some kind of curse?

Getting to the point; I almost always end up with textures that won’t stream to their highest resolution, no matter how close I get to the objects in question. I’ve tried;

  • Using the new optimisation view modes, it doesn’t look like a disaster, some objects show 1x under 2x over but to be honest I don’t know what the per object/texture solution is to those problems, and objects that appear fine in these view modes also have issues.

  • Increasing r.Streaming.Poolsize (although I don’t know how to do this permanently as it resets every time I close the editor). Note my stats below, I don’t think this is the issue as even if I set all textures to never stream i don’t top my pool, but I tried it anyway.

  • Changing the Streaming Distance Factor in Project Settings, this doesn’t seem to have an effect at 0.001 or 1000, it also resets when I close the editor.

  • Setting Maximum Texture Compression to 1024 (my max imported texture resolution) in Texture Settings.

  • Increasing the Streaming Distance in Static Mesh Settings.

I must be missing something here because it’s never really worked for me, on this scene I’m able to brute force the job and either turn streaming off or mark all of the textures as Never Stream but for others the ability to use this feature would be greatly appreciated.

Streaming Stats.PNG

Hi,

Sorry to give this a bump but could really do with a nudge in the right direction. Any help would be really appreciated.

Thanks,

Oz

You still have issues even with streaming turned off?

Whats your hardware specs, more so for your video card?

Texture streaming issues seems to be limited to working inside the editor so we have gotten into the habit of turning it off and then back on when baking the project.

You can increase the pool size permanently by adding it to the editor ini file but best practice is to add the r.Streaming.Poolsize as an execute node in the level blueprint. This way you can disconnect it when baking the project.

As far as we can tell this is a Ghost in the Machine bug that either you get it or you don’t and would be best practice to leave it as a part of the finalization process. (as in leave all optimization and environment issues for last)

Thanks for the reply and the tip RE best practice for setting the texture pool size permanently,

With streaming off it’s fine, things look as they should (as long as we have memory available to the GPU), that’s if we have each texture set to never stream or if we set it off globally via the command line. We’ve tried ramping up the streaming size but in editor it doesn’t seem to have an effect, interesting to hear that you have more luck with packaged projects. We generate cinematics from our scenes and these definitely still suffer from the same issue as we don’t package the project to do this.

Our hardware set up is as follows i7 6700K, 16GB RAM, GTX 1080, 1TB Samsung EVO SSD.