Download

Animation/ Root motion problem

Question, I’ve been trying to use a Root motion animation where my character jumps up and attacks. When I don’t have root motion selected at the end of the animation my customer snaps back. When root motion is selected it preforms the animation correctly but my character doesn’t leave the ground. Can someone help?

Sounds like you aren’t animating the root bone.
if you have root motion properly enabled, and the root bone is animated, then the capsule will be moved to where the animation directs.
Meaning there won’t be any snapping after transitioning back to a non root motion animation.

I was able to use other root motion animations just fine like the roll animation, and step back animation. It only seems to happen when my character leaves the group that it causes problems.

Also when I preview the animation and say process root motion it works fine.

Maybe share some footage so we get a sense of the kind of snapping.
you can ~ slomo .5 for a slowed down version. And show collision to check that the capsule moves.

https://photos.app.goo.gl/gDgespBThZW8yZeZ6

I was able to create this to show some pictures and a short clip

Unfortunately you panned away at the moment of gameplay where you would actually see the root motion moving up or stutter, so i can’t really tell whats going on.

Just to mention the Id10T error I made often enough. Make sure that root motion is enabled on the montage itself.

Another issue. When the attack starts you need to trigger the movement mode to something OTHER then “walking”. Or else the root motion Z may be ignored.

last bit from docs:
“The physics state of the Character is taken into account during Root Motion. For example, if the character physics is Walking or Falling, then the Z-axis of Root Motion will be ignored, and gravity will be applied. Characters will fall, go down slopes or up stairs. If the character physics is Flying, then the full Root Motion is applied and gravity is ignored.”

I didn’t think you needed to enable Root motion in montages if root motion was enabled in the animation it was created from?

I’ll also post a better video, and photos of what I have selected in my montage

good idea anyway, but if the issue is that you aren’t moving vertically, the answer is the movement mode.

I’m not familiar with the movement mode. It isn’t something I’ve come across with root motion. How would I go about fixing it?

Try disabling auto blend out in the anim montage.

Ok I’ll try that an give an update if it worked or not.

look up any livestream ragdoll/physical animation tutorial.

I’ve looked into a couple tutorials and all they show is just enabling root motion and it working. Nothing quite like the animation I’m using were the character jumps in the air to attack. Unless I missed something.

you did. Its part of the character movement component.
Search for “ue4 movement mode”

So I did see if using the movement mode would help and I didn’t my character still didn’t leave the ground. The tutorial I followed for combat didn’t use the movement mode node in the blueprint. I’ll post the tutorial for reference.

Ok I believe I found the solution. I just need to figure out how to implement it. I believe it has to do with flight mode to tell the game my character is off the ground but do I do that before the combo starts and then set it back to normal after?

I would suggest having a notify in the animation that calls back to the character variable and makes the mode modification.
do the opposite on the animation’s end to put back into walking mode.

I was able to get it to work! Thank you everyone!

Good form is to post your solution :wink:

Apologies, I was able to solve it by putting anim notifies indicating that my character was flying at the beginning of the animation and not flying when my character returned to the ground. Once I did that, I changed the movement mode to walking.