Animation Blending Causing Double Audio Notify

I have set up footstep notifies on some animations that get blended together. But when the animation is blending between two different footstep animations notifies on both animations play at the same time.

Is there a way to set up a priority system of the animations to only play one at a time? Or is there a way to have a separate anim track that only plays the notify sounds once?

Every animation notify has a property called ‘Trigger Weight Threshold’, which determines how much much weight the animation sequence needs to have to trigger the notify. By default this is a tiny number so that notifies will trigger no matter what the weight but for blended sound notifications you’ll want it to be higher. If you set them to 0.5 then only the animation with the greater weight should trigger sounds. Let us know if you have any trouble with it, I’m not sure if it will need to be less than 0.5 depending on how many other blend weights are involved.

All sound notifies contributing to a blend should be set to 0.5, otherwise I would assume that those remaining at 0.0001 would continue to play back all the time. I would assume that if you set weights to 1 in a blended animation the notifies should never play, maybe try that and bring them back down until it seems right? If all of your sounds are still playing with a threshold of 1 then maybe there’s something wrong on our side.

Hi Matthew! Thank you for your quick response.

I have tweaked the weights of the notifys with many different combinations of numbers but my issue is not yet resolved. I am still getting the sound playing twice.

To clarify: should I set all weights to 0.5 or should I only set the dominant animation to 0.5 and have the other sounds at the 0.0001?

Hi Matthew. All of my sounds are indeed playing at the threshold of 1.

Matthew: since my sounds are still playing with a threshold of 1, does that mean this is a bug?

Yes, I’ve confirmed it’s a problem in a simple example here so I’ve added issue UE-7481 to look into fixing it. All I can really suggest for now is to only add sound notifications to one animation that is going to be blended. If for example you have a walk that blends to a run, the walk footsteps will be played more quickly as the run animation becomes higher in weight, which may or may not line up with where you’d like them for the run. Sorry for the inconvenience but thanks for reporting it :slight_smile:

Hi Matthew, is there an update on this issue or a webpage that I can access to have updates on it? Thanks!

I’m afraid we don’t have a public facing way of tracking issues at present. I can only tell you that it hasn’t currently been fixed and there isn’t an estimate of when it will be I’m afraid.

I see. Thanks. If you could somehow increase the priority of this bug, it would be most welcome. As things stand, you can’t have sounds and blendspace together. This is really a problem for us.

I’m really sorry that this took so long to figure out, I chatted with one of our animation guys yesterday and he remembered a property of Blend Spaces called Notify Trigger Mode:

29846-2015-02-13_09-12-23.png

This defaults to All Animations but when dealing with Sounds you’ll want Highest Weighted Animation. I’ve tested this out and it has the result you’d expect, even making sure that only one set of sounds plays when animations are equally weighted.

I still think there is something wrong with the Trigger Weight Threshold but you shouldn’t need to worry about it when setting up sounds.

See the new answer up top.

Great, thanks!

Hi. i know Epic has some form of process to track how important a certain bug is depending on community interest and i would like to add my interest in this bug being resolved.

Thank you so much!!

Hi this is almost working for me except when Idle is weithing more than Jog in my situation than there is no sound because idle has no notifications. Any way to work around that?

Why isn’t this tagged as an answer?
It looks is going to solve our footstep issues! Thank you!

Could you reopen this issue please? UE-7481

I’ve been wondering about this for much too long! Thank you very much!

this hasnt worked for me… is there anything else needed to do in the animgraph if for example we are using a layered blend per bone to connect 2 blend spaces?