Download

Animation Additive Layer Tracks Not Working?

Anyone experiencing the same thing ?

4 Likes

Having the exact same problem.

2 Likes

Also having the same problem.

1 Like

Figured it out. In UE5, “Additive Settings” now defaults to “No Additive”

Go into the Asset Details and change it to Local or Mesh and it should start working.

Edit: Be warned that “mesh” doesn’t work with sequencer.

2 Likes

Same truble. Really don’t know what to do with that issue:(

it’s strange, but my mesh just dissaper on animation (when game running), when i change it Addtive to Mesh or local

1 Like

I have a solution to this question. Apparently, by default, layers are disabled and you can’t turn them on. Solution - after editing the animation, go to the menu create asset - create animation - current animation-preview mesh. This way you will create an already fixed animation without layer and everything will work as it should.

13 Likes

Thanks!

Thanks a lot! this worked, even though I wish this will be fixed soon cause additive tracks are way more flexible

Thank you so much!!

Why does it take this much Fkery what was once a very good, almost perfect and divinely perfect workflow from UE4?

Please explain!

The explanation is (from what I can gather from MY testing) is that UE5EA is still a work in progress and this doesn’t work correctly — yet.

Yes, I’m reaching, but I’m willing to give them the benefit of a doubt at ATM. HOWEVER, that doesn’t change the fact that this is a serious problem that needs to be addressed. I DO NOT LIKE the idea of creating a new animation, but as an interim solution (sigh) I can live with it.

Thanks, y’all, for figuring this out, it was bugging me.

Thanks! You saved my life

This solution worked for me - thanks!

This solution also worked for me, thanks

I noticed that when I try the fix mentioned here (Create asset etc) it breaks root motion and no longer works with motion warping.

1 Like

Did you try just changing the additive settings?

I can confirm this is also broken in ue5-main, and mainly caused because Epic carried additive layer track apply proces to compression step. Probably will be fixed soon, but not sure how long it’ll take.

hey, were you ever able to figure out how to fix the root motion? struggling with the same thing myself

Thanks. Hopefully this will get fixed. Almost all of my animations have additive layers. Everything looks broken in UE5.