Anim Trail not rendering in Android Mobile!?

Dear Unreal,

Recently i’ve come into a problem that my anim trail is not working in my mobile Note 7. I package using OPEN GL3.1 settings and i can’t get the anim trail to be render when launch in mobile, when in editor and PIE everything is okay. Please advise which solution can i try? i tried finding everything in materials, particles but settings are good to go. Have no clue why after package and install in android doesn’t show up.

Okay. I tried on Packaging using Open GL ES2 for android then trail is working. Does this means OpenGL ES3.1 doesn’t support? Please advise soonest is this a bug?

Dear unreal community. Is this a bug for Packaging es3.1 for anim trail? Please advise as I Package es2.5 everything works but not in es3.1 Packaging. Please advise and check soonest.

Dear Unreal Engine,

Is this a bug in 4.13? please advise ASAP as we’re currently stuck here. Package in ES 3.1 doesn’t show trail but in ES2.5 is okay. Please advise.

Hi Dizzy,

When I try an openGL 3.1 build on S7 Edge I don’t get an issue that I can see. I get consistent results in both the editor and device.

Can you put together a sample project that demonstrates your issue and I can have a look to see if there is something there. I just used a default third person character with the trail triggered on the walk animation.


Dear Tim,

I believe it might be the Note 7 issue. Since this phone is no longer continue, i guess it’s not a big problem =)

Hi Tim,

I tried on S7 Edge still no luck, using 4.14 preview 3 now, trail not showing in Package ES3.1 but show on ES2. Let me get some screenshot on the materials and the particles, as well as some gameplay of the game in mobile…

This is the material setup. things are okay in ES2, but i tried again package to ES3.1 problem again, editor works great.

Hi Dizzy,

I was able to get this to reproduce on one of our Mali chipsets, whereas the device I originally had was using the Adreno chipset. Looks to be an issue there really. I’ve submitted a ticket for this to be investigated and you can follow the status here: Unreal Engine Issues and Bug Tracker (UE-38961)



Ah… It’s the Mali chipsets problem, indeed i tried on Mali GPU instead of Adreno. Thanks.