Android Storage Permissions

I cannot get Android permissions for READ/WRITE on STORAGE , via USB or via GOOGLE PLAY , i always have to enable them manualy from the OS!
i have on my instance an android request permissions, but it never shows up. Android runtime permissions are ENABLED. Am using 4.18.3
Here are some more screenshots

https://forums.unrealengine.com/development-discussion/android-development/1493282-android-storage-permissions

We are having the same issue. Not sure if we’re missing something or if this is a bug. We were hoping to launch, this week, but this is game breaking; no one wants to give their players instructions on going into app permissions and enabling storage. Hopefully, someone has a fix!

Take a look at my forum link, there’s the only solution I’ve found. Cheers good luck!

I am encountering the same issue. Packaging the game for shipping and uploading to google play store. Anyone who downloads the game must manually turn on storage permissions in order for it to work. Desperately needing a solution.

In case you don’t want/can follow the forum link, just check “Use ExternalFilesDir for UE4Game files?” on Project settings. Take a look to embedded below: image

Does this not result in your save data getting deleted on any uninstall or future update?

android.permission.WRITE_INTERNAL_STORAGE

add this in Settings-Platforms-Android-Advanced APK Packaging-Extra permissions.

android.permission.WRITE_EXTERNAL_STORAGE if you Need to save on external SD Card.