[Android] Particle emitter moving with up and down camera movement

I’m trying to have some ‘dust particles’ float around a player on an android device. It works fine on PC / mobile preview but on the mobile device (S7) when looking up and down the particles move with the camera Looking left and right however works correctly as well as moving the player forward back left and right and the particles are fine - it’s just when the player looks up or down and the particles move with the camera.

Reproducible in the first person template on a default android build where the emitter is placed on the level outside of the first person char blueprint

See this project (newly attached here):[exampleProject][1]
To reproduce:

  • build project for Android ETC2
  • Run on device (I’m testing on a S7 Exynos)
  • Move the camera up and down using the right thumb controller

Anyone have some ideas on how to workaround this to get the particles to appear normal when looking up and down on android?

120887-daydreamtest.zip (213 KB)


Thank you for bringing this to our attention. I have tested and verified this issue as a bug and have reported it in [UE-39357][1]. Please let us know if you have any additional questions.

Thank you!

Unreal Engine Issues and Bug Tracker (UE-39357)

Thanks -
Is there no workaround that could be used in the meantime as I guess it’s too late to include in any 4.14 hotfix right? Any a fix makes it into 4.15?

I noticed this in the linked ticket:
" If you have more than 1 particle emitter, it seems to correct the issue. "
That did not work as a workaround for me - I added two emitters and had the same problem. Is this still possible for 4.15? Makes alot of the FX available on the marketplace unusable for mobile VR :frowning:

When testing it, I did notice that placing more than 1 particle emitter into the project did resolve the issue for me. This bug is still on the to do list, but it does state that it’s on the list for 4.15. This could change, depending on what pops up between now and then.

How did you add the second emitter? was it just dropped onto the map or was it added by blueprints?

Was it the same emitter or was it a different emitter entirely?

Just trying to get that possible workaround working in the meantime… but so far not having any luck (any of sharing the project maybe?)

I just copy and pasted the one you had in the level. Then to double check behind myself, I deleted them all and did it again. Have you tried that yet, does that work for you?

Did not work for me unfortunately, copied and pasted the existing emitter as seen here:

We’ve tested on both a and Adreno device and the issue has occurred for us. I saw that the issue was resolved if I had more than one particle effect on the S7 . It’s possible that there is a difference between the way the devices are working. This issue is still being worked on by our Developers, I see it’s currently in progress.

We will let you know once we have additional information. :slight_smile:

I tested the duplicate effect on a Pixel which has a Adreno.

FYI: I re-uploaded the project attached in the original question as the link had expired.

Thank you for updating your link. This issue has been fixed for 4.15.

This was a problem affecting GPU particles in projects with MobileHDR off (all mobile VR). As a workaround in 4.14 you can switch particles to be CPU instead of GPU sprites.

Thanks switching to CPU particles indeed fixed the problem