Android packaging unknown error

Every time i try packaging my game for android I get a unknown error at the end and the folder in which I try to create the game is empty. When i make it for Windows it works fine. I also get the same unknown error when i try to package project Tappy Chicken game.
I have tried several times to reinstall CodeWorksforAndroid, but still i get the same problem.[link text][1]

107410-spēlerun.log (249 KB)
I am new to Unreal Engine and i could use some help at this matter.

I tried migratig files to new project but it also did not work.
[link text][1]
This is where the errors start to show up.
107444-thingsgetmessy.txt (10.1 KB)

How it looks!


  • Delete your Intermediate and Saved folders from your project.
  • Please make sure you’ve added your Android SDK information to the Project Settings > Android SDK section in the editor. Example:


  • Please make sure you’ve followed the [Android Documentation][2] for setting up Android Development.
  • Make sure your CodeWorks is using example:


If you are unsure, please upload screenshots of your own, thanks!

Thanks for the replay!
I tried what you said. Installed CodeWorks 1R4u2. Set up Platforms Android-SDK and deleted Intermediate and Saved folders. But i still cant package my project. I get an error that it cant find Intermediate/Android/APK/bin/[NAME]-debug.apk.

[link text][2]

This is the error I see: Error reading project file E:\Sp?leRun 4.13\Sp?leRun 4.13\Intermediate\Android\APK\build.xml: Invalid byte 2 of 3-byte UTF-8 sequence.

If you delete this folder: E:\Sp?leRun 4.13\Sp?leRun 4.13\Intermediate\Android while the editor is closed and see if that resolves the issue. It should recreate that file that is stating it’s invalid.

Thank you for the response! I tried to delete the Android folder when the engine was closed. But when I tried to package I got the same error. Could not find a part of the path 'E:\SpēleRun 4.13\SpēleRun 4.13\Intermediate/Android/APK/bin/SpēleRun-debug.apk

[link text][2]

Can you create a blank project and see if it’ll package for you? Basically, if your project is only blueprint, create a blueprint project, if it’s both, then set it up that way, etc.

I’m looking into the character encoding error I see and will get back to you as soon as I can. In the meantime, please check the packaging in Android of a blank project for me.


I made a blank blueprint project (Mobile/Tablet; Scalable 3D or 2D; No starter content). And I still got the same error I got in the beginning, even when I deleted the Intermediate and Saved folders. It seems it might not be [link text][1]the project fault.

108578-myproject.log (240 KB)

  • Try running the engine as
  • [Verify your issue isn’t the same as this AnswerHub post][1]
  • [I’d also go through the Android SDK set up again][2]

Android Build Failed - Mobile - Epic Developer Community Forums
[2]: Setting Up Unreal Engine Projects for Android Development | Unreal Engine 5.1 Documentation

I tried running as , but it did not work.
I dont think that the issue is the same as in that post. And I am not sure if I could implement the solution that was used there since my project is all blueprints. I also did go through the Android SDK set up. I have tried going through it several times. The only difference I see is that I use VS 2015 not 2013, but it would matter if my project had C++ code.

4.13 requires VS2015 - so you should be fine there. Other helpful tips I have been able to locate regarding this error is that moving the NDK may help. Just make sure that where you move it doesn’t have any spaces in the file path. Another suggestion is to change the API level to ‘latest’.

So i need to move the android-ndk-r11c folder someplace else?

I tried changing NDK and SDK API level (both, only SDK and only NDK), but no luck. Moving the NDK if I did how I think I had to do it had no result.

Have you tried renaming your project entirely from “SpēleRun” to “SpeleRun”? It might just be the ē causing the whole issue.

I did try it with this tutorial, but still got the error.

Did you verify that it changed it within all of the project settings? If not, double check that Project Settings > Project - Description has been updated as well as Project Settings > Platforms - Android > APKPackaging

Make sure that once you modify the settings, you delete your Saved and Intermediate folders.

Provide updated logs as needed, thanks!

Will All the name changing my project packaged further then before, but I got another Error at the end. This is how it looks. Is the APKPackaging and Project Description is correct?
I very appreciate all the help you have given me. alt text

[link text][3]

Based on the error that I see:

[2016.10.06-18.30.04:702][506]UATHelper: Packaging (Android (ETC1)): Program.Main: ERROR: AutomationTool terminated with exception: System.IO.FileNotFoundException: Could not find file 'E:\SpeleRun 4.13\SpeleRun 4.13\Intermediate/Android/APK/bin/SpeleRun-debug.apk'.

[2016.10.06-18.30.04:703][506]UATHelper: Packaging (Android (ETC1)): File name: 'E:\SpeleRun 4.13\SpeleRun 4.13\Intermediate/Android/APK/bin/SpeleRun-debug.apk'

You should be able to delete the Intermediate and Saved folder from your project and it should get over this point.

I am concerned about: E:\SpeleRun 4.13\SpeleRun 4.13\Intermediate\Android\APK\bin\AndroidManifest.xml:1: Tag attribute package has invalid character ‘[’.

But that should be resolved too, once the Intermediate folder is deleted.

You’re welcome for all of the support, sometimes these issues are tricky and other times they’re a breeze. :slight_smile:

I deleted the folders, but still get (Tag attribute package has invalid character ‘[’.) and (‘E:\SpeleRun 4.13\SpeleRun 4.13\Intermediate/Android/APK/bin/SpeleRun-debug.apk’.)[link text][1]

110026-spelerun-backup-2016.10.07-20.14.55.log (370 KB)

Can you send me that file?

E:\SpeleRun 4.13\SpeleRun 4.13\Intermediate\Android\APK\bin\AndroidManifest.xml