Android not recognized in device manager

I followed this Tutorial: link text

Everything worked. But my android device (Sony Xperia Z3) does not get recognized, no matter what. My device is in debugging mode and connected via USB. My environmental variables are set up. My SDK and JDK path have all been set up. But it still does not get recognized. Yesterday it got recognized, but i had to uninstall and reinstall UE4, because there were some errors and stuff like that… So any help, or why this problem occurs? I can post some screenshots here, if needed.

ggez27,

Have you downloaded the drivers for the Sony Xperia Z3?

Yes, i did. I even tried it on my Note 3. No Result. I looked into forums and found this: link text

What do they mean with rebuild the engine and how can i do it?

If you have the source version of the engine, you can open the .sln and rebuild the engine for Android. But if you aren’t sure how to rebuild the engine, then you’re likely using the binary version of the engine, out of the Epic Games Launcher.

  • Could you show me your command prompt window?
  • Have you tried various other USB ports and cords?
  • Did you ‘trust’ your computer with your device?

If you’re not sure, you can revoke the authorizations within Settings > Developer Options > Revoke USB Debugging Authorizations.

Hello i did everything, still same. In my command prompt is only my phone nothing else. I downloaded UE4 by the epic games launcher. How could i rebuild it from there, since i don’t have the .sln file?

You wouldn’t be able to rebuild the engine if you’re on a binary version (from the Launcher). You can rebuild your C++ project in Visual Studio if you’re working in a code project but I don’t think that’s relevant here since you’re on a binary version of the engine.

Could you please upload a screenshot of your Command Prompt window you’re using to install the Android projects with?

Thanks!

So…Is the command prompt window inside the editor or in my library, or where can i find it?

It’s in Windows. So if you search for “Command Prompt” it should appear for you.

129296-3-9-2017+10-32-20+am.jpg

Hey ggez27,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!