Android for distribution fails to load on device

It successfully compiles. How ever the game crashes out almost instantly if I have for distribution checked. If I uncheck it. The game runs and I even see google play services window at boot if I uncheck for distribution.

Log files say these things I think are the cause.
10-21 17:47:52.477: V/GamesNativeSDK(1767): Using classes from /data/data/com.epicgames.Marble/app_.gpg.classloader/b6757673c393a41909bbab0d950640e3.jar.
10-21 17:47:52.480: I/dalvikvm(1767): Failed resolving Lcom/google/android/gms/games/NativeSdkCallbacks; interface 7 ‘Lcom/google/android/gms/common/api/GoogleApiClient$ConnectionCallbacks;’
10-21 17:47:52.481: W/dalvikvm(1767): Link of class ‘Lcom/google/android/gms/games/NativeSdkCallbacks;’ failed
10-21 17:47:52.481: E/GamesNativeSDK(1767): Exception in dalvik/system/DexClassLoader.loadClass: java.lang.ClassNotFoundException: Didn’t find class “com.google.android.gms.games.NativeSdkCallbacks” on path: DexPathList[[zip file “/data/data/com.epicgames.Marble/app_.gpg.classloader/b6757673c393a41909bbab0d950640e3.jar”],nativeLibraryDirectories=[/vendor/lib, /system/lib]].
10-21 17:47:52.481: E/dalvikvm(1767): ERROR: couldn’t find native method
10-21 17:47:52.499: I/ActivityManager(9664): Process com.epicgames.Marble (pid 1767) has died.
10-21 17:47:52.499: I/WindowState(9664): WIN DEATH: Window{429eb888 u0 com.epicgames.Marble/com.epicgames.ue4.GameActivity}

I have a possible work around and can perhaps shed light on what the issue is. Using 4.5.1 compiled from source or not. I compiled out both with and with out distribution checked. I extracted the apk files from both results. I then took the AndroidManifest.xml file from the distribution apk and copied it over the one that had distribution unchecked. I then deleted the signing folder. Rezipped the files, and renamed it to .apk. Resigned it, zipaligned it, and it works! Google play store lets me upload the apk file and it doesn’t crash back to the desktop when I run it.

I just wanted to update that 4.6 does NOT fix this issue either.

Howdy SteveFox,

Thank you for reporting this issue. I have tested this issue on the new 4.6.1 build and on the 4.7 preview build on the error is still occurring. I have however, tested the issue on a newer internal build and the error is no longer occurring. I am unsure as to when the fix for this will be implemented into a released build but the issue has been resolved.

Please let me know if you have any additional questions.

Thanks and have a great day!

Thank you for confirming the issue. I appreciate the information about it not working on 4.7 either. I’m glad to hear it will be fixed eventually since it is in the internal build. Thanks.

Confirmed still has the same issue on 4.7

Hey SteveFox,

Thank you for the update about the issue not being resolved in the 4.7 release of UE4. We have just released a hotfix for 4.7 (4.7.1) and I was wondering if you would be able to give this build a try and let me know if this issue has been resolved.

Thanks!

Getting the same thing on 4.7.1 The same fix still works, so I think its the same issue.

Hey Steve,

Would you be able to give this a shot on 4.7.2 and see if this still occurs? I may have to re-visit this issue.

Thanks!

Same issue on 4.7.2

We just recently put a demo of our game up on Google Play. We ran into the same problem. Hopefully it is ACTUALLY the same problem and can help you.

Get this: in the manifest where your package name is, the com.whatever.yo, we had to leave the last part at default where it automatically generates it based on on the project name. Our package name through Google was com.deviousgamers.ihatemyjobdemo, and we had to rename our project to ihatemyjobdemo for it to generate correctly. Typing in the name manually in the manifest did NOT work.

Obviously it ended up working, or we wouldn’t have a demo up. It sounds bizarre and you might initially be like Nah dude that’s not the issue. But it’s worth a shot. We were in a pretty desperate stage when we were trying things like that lol.

Here’s the demo if you’re curious btw
https://play.google.com/store/apps/details?id=com.deviousgamers.ihatemyjobdemo

EDIT: We are using 4.6.1. 4.7.x drops our mobile fps, unfortunately.

I appreciate your response. In 4.7 those settings are finally inside the editor. I tried changing the last part from .Marble back to .[PROJECT]. It did seem to add the .Marble back correctly during the cook on the files. Unfortunately it did not help and it instantly drops me back to the home screen still. I actually seen your app on the store the other day when I was browsing. I thought to myself great idea for a game haha. I wish you luck with your game. Thanks again for the information. I will leave the end part as default from now on just in case it helps in the future.

Dang, too bad.

And thanks!

Hey SteveFox,

Thanks for all of the information that you have provided. I have entered JIRA report UE-11350 into our bug database so that the issue may be addressed in a future release. I am unsure as to when this issue may be resolved but I will be sure to keep you posted as I know more about the bug.

Thanks and have a great day!

Howdy SteveFox,

I have just received some information about your issue. When you are packaging your project for Distribution, do you have the Distribution signing section filled out under the Project Settings>Android section?

Also, have you created a Key Store for your project. This is vital when packaging your project for distribution.

Thanks!

Yes I transferred all information over from the old xml file setup. Yes I have created a key store file. Yes I moved it into project/build/android. The project would fail to build If I had not. As I said, the project builds it just doesn’t work.I have to cook two versions each time. I have to decompress the apk, copy the dist version of the file AndroidManifest.xml over top of the non dist version, recompress, ,rename, resign, and realign. Then it works.

Which version of the Android NDK and SDK would you be using? Also, Could you provide the two copies of your AndroidManifest.xml files?

Thanks!

Sorry about that. When a comment is provided by myself, it will mark it as resolved if I provided the first answer. I will be sure to check as I respond to your comments.

Just noticed this got marked as resolved. Funny I guess missed that one.
Can I get the fix since this was resolved?

Thanks. I’m using the version included with the download tadp-2.0r8-windows. I’d like to use the latest version as it has had a lot of optimizations but last I knew you had to use this version. I will get those posted as soon as I get home. I can also send would need to be direct all three packages if you want them. Cooked with out dist, with dist, and then the fixed version that works.