Android for distribution fails to load on device

xml files in one archive. Let me know if there is any thing else you need. Thanks

It wlink text

Was not fixed in 4.7.3 either.

Hey Steve,

I may have found this issue. You may be having issues with proguard txt file not transferring over with upgrading your project with new builds.

Go to this location in windows explorer: Location of your engine>4.7>Engine>Build>Android>Java. You should be able to see a file named proguard-project.txt . Please let me know if you do not.

If it is in that location, Open up a new windows explorer window, and locate your Unreal projects folder. Locate project you are attempting to package and use this route to check and see if proguard-project.txt file is located within this location: [Project]>Intermediate>Android> APK.

If it is, delete proguard text file in projects folder and copy and paste text file from Java folder.

Let me know if this helps with issue any.


It did not seem to help. I was hoping it would as file inside project was only 2KB. one inside java folder was 3KB. Using new file did not fix it though.

Hi SteveFox1620,

I spoke to Android dev with regards to users being obliged to use tadp-2.0r8 and he advised that upgrading is fine as long as you are using 4.7 update of engine, but you should make sure you have SDK 19 and NDK checked when installing. So feel free to update, it should be fine if you make those two changes.

So when Google Play services were enabled for our about-to-be-released launch version, I experienced your problem. Crashes on distribution build, works fine with development or shipping without distribution. Google Play unchecked, distribution works.

I did what Sean said about updating my proguard file, and made sure to include it in Intermediate > Android > APK and in Build > Android, just to be safe.

Still didn’t work.

However, I found this post:

You add this to proguard file:

-keep class * extends {
    public *;

I had tried that post’s solution before with no success, but now, combined with Sean’s advice of updating proguard, and THEN adding this code, I am now able to use Google Play services and launch my game with distribution.

I really hope this helps you out.

worked for me thanks

I opened up my file and found that line all ready in there. Are you saying you have it twice in your file and that fixes it?

It wasn’t in mine, so I guess your problem elsewhere. :frowning:

Thanks any way. At least someone tried. I’m still wondering why this thread is marked as resolved. It’s no wonder no one is getting any help on this known issue.

Still an issue in 4.8.1

Still can’t get a Shipping/Distribution to work I’m having same problem. I think it has to do with game now being put into a folder UE4Game.

So even when you’re able to build a “For Distribution” / Shipping game it will not work from app store or installing it locally. For now you’re stuck with a non Distribution / Shipping game

I’m having exact same problem


Build configuration: Shipping

Full rebuild

Not Working:

Build configuration: Shipping

Full rebuild

For Distribution


A full shipping for distribution build will give error:

Failed to open descriptor file

Hi ,

We will be tracking issues you are experiencing on post that you made:

Please refrain from posting your issue on multiple threads on AnswerHub. We will address issue on your post. Make sure you include any logs you can, as requested by wittlief.