Android displays a button with no function

Hi, I test some UE stuff on mobile devices, in my case a HTC One and there is one thing I’d like to influence:

Sorry for showing you 50 shades of grey, but I hope you can see the “button” in the bottom-right corner. This one is automaticly generated when launching on my Android-Smartphone but it has no function. This button is not displayed if I launch the project on iOS (IPad Air 2). How can I hide or use this button? I didn’t find anything in the UE-documentation. Thanks in advance :slight_smile:

Howdy TGE,

Thank you for reporting about this button you have been seeing. I am going to need a bit of additional information before I begin looking into this issue. What version of UE4 would you be using and is that version a Binary build of the engine or a Source build? What is the version and model number of your HTC One?

Any additional information would be greatly appreciated.

Thanks and have a great day!

Hi, thanks for your reply! I’m using version 4.7.6 but this button already appeared in version 4.7.5, too. I can’t give information about previous versions. I’m using a binary build. The model number (according to the settings of my smartphone) is simply “HTC One”, it runs the android version 5.0.2. If i run the HTC Sync manager it also displays me the “software number” 7.19.401.2. Hope that helps, I look forward to hear from you again,with best regards,

Hey TGE,

I have just attempted a quick repro of this issue and have been able to see the options menu indicator dots appear. Would you still see the options indicator if you add this:

@Override public boolean onCreateOptionsMenu(Menu menu)
return false;

to in Engine/Build/Android/Java/src/com/epicgames.

Let me know if this if this helps to resolve the issue.


Hi, thanks for helping me. Unfortunately I won’t be able to test this before monday, but I will do and I will write down the results here. Is there any possibility to use this button? Thank you again, Tim

Hi again, inserting the code (at least if done like below :S ) did not only not help, it causes an error if I try to launch a project on Android now (output log below)

Do you have any oother ideas how to fix it? Thanks :slight_smile:

The phrase “disable the menu button???” is written behind 2 “/”. In Java this is a simple comment behind a line that wont affect the compiler, it’s… well it’s just a comment. If I delete the suggested code again packaging is possible.
As far as I remember I never had the failure you described.

Does this solve the issue?? I have just searched the answerhub, but maybe this helps you, too?

Another answerhub thread with a possible solution

Also referenced in the forums once:

See Here

Anyway, there are other people with this problem, too, so a solution provided by Epic would be great.


Thanks for letting me know about the code, like I said my experience with code is very limited.

Were you able to locate the failed build output log to attach as a txt to this thread? I am betting you’re getting the failure because the code addition isn’t working as expected, but I do want to double check and see if there’s anything I can suss out in the log.

You can even run a build with the code in place, and then remove it again and see if your build still fails, and we’ll try to find a different way to remove the button. Also, I am curious if the links mentioned below by LeFxGuy are of any assistance.

Thanks very much!

Unfortunately this does not solve the problem, but at least it does not cause an error while launching.

Howdy TGE,

Sorry to hear about that workaround I provide not helping the issue. Would you be able to attach your full build failed log so I can have a glance at it?


Hey TGE,

Just wanted to check in with you and see if you are still experience this issue. If so, would you be able to provide the information asked for in the post above so that I may be able to further investigate.

Thanks and have a great day!

Hi, sorry for not responding. Unfortunately I can’t reproduce the log because my smartphone is in repair at the moment. Nonetheless I guess the log won’t help to find the answer…

I have also found a bit of additional information that may help with the issue. Multiple other users have reported wanting to get rid of the three-dot options menu and have provided fixes here: android - How to disable/hide three-dot indicator(Option menu indicator) on ICS handsets - Stack Overflow

Let me know if any of these are helpful once your device is ok to test again.


Hi TGE, were you able to test the suggestion that Sean Gribbin posted below?

No, my smartphone is still in repair… I can’t wait to try it and I will reply if I did.

just tested it and could not reemove the 3 dots

Please have a look at the first answer of this thread:

This is the legacy menu overflow button. Easiest way to get rid of it if you are targeting Android 4.0 or higher is to set the minimum SDK version to 14 or higher.

If you need to keep supporting less than 4.0, you can do this by instead providing a requirements override file:

Create a file in your project’s Build/Android directory called ManifestRequirementsOverride.txt and put the following in it:

	<uses-sdk android:minSdkVersion="9" android:targetSdkVersion="14"/>
	<uses-feature android:glEsVersion="0x00020000" android:required="true" />
	<uses-permission android:name="android.permission.INTERNET"/>
	<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE"/>
	<uses-permission android:name="android.permission.ACCESS_NETWORK_STATE"/>
	<uses-permission android:name="android.permission.WAKE_LOCK"/>
	<uses-permission android:name="android.permission.READ_PHONE_STATE"/>
	<uses-permission android:name=""/>
	<uses-permission android:name="android.permission.ACCESS_WIFI_STATE"/>
	<uses-permission android:name="android.permission.MODIFY_AUDIO_SETTINGS"/>
	<uses-permission android:name="android.permission.GET_ACCOUNTS"/>
	<uses-permission android:name="android.permission.VIBRATE"/>

If using IAP add:

	<uses-permission android:name=""/>

If using GearVR add:

	<uses-feature android:name=""/>