Download

Android device fails to join or create a session.

Hi. So I package my game for windows and for android. I create a session on PC. Other clients on PC can find and join the session. However my android phone fails to do so. Also create session on my phone fails every time.

All devices connected to the same Wi Fi router. Use lan is ticked where it is needed. Blueprints should be all fine since PC to PC works.

[OnlineSubsystem]
DefaultPlatformService=Null is added to default engine ini file.

Am I missing some steps to make it work on my android device?

here you can see me running my project on two windows clients and then the same project on android emulator. See the difference: https://youtu.be/1KbyiJ6LqdU
I have no idea why would android fail when it worls just fine on windows. Is there something in my project settings that I might be missing?

Please help!

you may try to search about the problem before posting which will save you more time :slight_smile: , here is the same prob i faced " Android multiplayer wlan: Android as host device problem - Android Development - Unreal Engine Forums "read it till the end and you may get your answer as UE4 officially still doesn’t support android client/server and to get it work its not an easy way .

BTW if you like add me in youtube or Facebook and we may help each other in the future and may be make a team when the time come as my intention is toward android developing too .

Hi mhnoni. I am aware of the thread you linked. I actually posted there and you answered me. See last three posts there. :slight_smile:

The guy who made that thread had problems getting android working as a host. He says that PC as host and android as client works. However I can’t even get that working, nevermind hosting on android. I just get failed attempts to find join or create sessions. I feel like my blueprints are fine (since pc to pc works), maybe there is something crucial in project settings that I failed to setup correctly.

Hehe sorry didn’t check your name :slight_smile: as you opened a new thread for the same problem and its better to post the same problem in the same thread to give the attention to epic team to solve it and for people who is facing the same issue can find the solution easier . anyway if you can’t find the pc then its most probably you have a firewall or port blocked in your pc , btw test 2 pc and see if you can make it work , if you don’t have 2 pc then package the project for pc and run both client and the server in the same pc if you got problem there then you have problem in your project setup .

Yes I have my project packaged for PC and everything runs perfectly(you can see it in my video). I open two projects on PC and they find and join each other np. Then I open same exact project on android emulator and it fails with everything.

I opened a new thread because I can’t even get PC host-android client to work. And the thread you linked is about android as a host issues.

Btw mhnoni my Youtube chanel and FB names are the same. If you like, hit me up on either.

i will make a small fast tutorial + project and add it to youtube , you may check it and test it in your device later , here is my channel (N nOni - YouTube) once i add it i will let you know .

Will check it out! Thanks!

I’ve made a tutorial as a favor for some people who asked and they are facing same issue hope it will narrow your problem , one of the developer really helped me a lot to fix my problem and now its my turn to fix someone else , if you fixed yours then you will have to help someone else too :slight_smile:

https://forums.unrealengine.com/showthread.php?101665-Tutorial-Simplest-way-to-make-multiplayer-game-in-UE4-only-for-beginners-android-pc

Ive been helping people on these forums since 2014, but there are still a lot of things that I need help with too. :slight_smile: I will check your tutorial and project out after work tonight. I really appreciate you trying to help mhnoni!

thats cool to help each other as we can’t reach our goal individually which is to make our best game in less time . contact me for any help in case you need .

Hello again. So I watched your vid and all. And I can say that I there was nothing wrong with my project setup. Everything I did was slam bang correct.

So after bashing my head against a wall for a few hours, I discovered this most ridiculous (bug?) thing since I started using UE4.

Basically if I use UMG to trigger my create/find/join session events, it would fail instantly. However if I bind all these events to Android back, android volume up/down buttons, IT WOULD WORK NO PROBLEM!!!

So I am now able to use my phone to join a session created on windows. But only if I use android phone buttons to do so (otherwise create/find/join session nodes return failed results instantly).

Now I don’t know what a hell is going on here, but if I use android buttons everything works fine!!!

So I am reinstalling Unreal Engine 4, because this is beyond stupid.

Thanks mhnoni for all your help. And for epic staff who answered every thread on this subforum except mine-thank you not so much.

:slight_smile: my pleasure .

Hi!
I am facing similar problem. Can you please help me?
Is there any other way to host/connect between android and pc, or i have to use hardware android keys?)
Thanks in advance.

Hi. I don’t have any issues since 4.12. What problems are you having?

I can host server on android device (at least i dont get errers), but i can’t connect to this server from PC client.
And vice versa, i cant connect to PC server from android client.

What engine version are you using? Can you connect pc to pc?

I’m using 4.12. Yep, 2 builds on the same pc connects to each other, so its probably something with my android build.

Try to do what I did here. It seams silly but it really worked when I just used android buttons instead of UMG back then.

Just yesterday, both Create Session and Join Session were working on my Android phone and I was able to connect it with my PC. Today, my phone cannot create or join any sessions.