Android app installed but not showing on phone

Hello everyone

I’m deploying a google VR cardboard game on a Samsung Galaxy Note 4, and it seems like when I install it via the bat file generated by the packaging process the app doesn’t show up in the phone. After various tries I noticed that if I package the game with armv7 it works normally and it’s installed as it should ( shows up on the phone and works ). But if I package it using the arm64 support the app installs without any errors but it doesn’t show up on the phone which means I can’t even launch it.

I tried to install the arm64 one on a Huawei Honor 5X and it worked normally, but I want to make it work on the galaxy note 4 because it’s the phone we’re working with for our project ( undergraduate project ).

So I’d really want to know how to make the arm64 version work with the note 4, unless the vr apps doesn’t require arm64 to work perfectly ( means I can package using armv7 without any loss of performance or cause any problem ) then I’ll just simply package in armv7.

Note: the problem is not in the android SDK, I tried these combinations :

armv7 : worked on both phones
arm64 : worked on the huawei but not on the samsung

I just checked and noticed that the kernel of the galaxy note 4 exynos version has the instruction set arml7 which is a 32bits. which is weird because it’s 32 bits for an octacore cpu.

I’m not sure if the android system is in 32bits or if it’s the hardware. Anyway, now I’d like to know if I can do anything to upgrade my android system to 64bits, or just package to 32bits ( armv7 ) and have a good performance in VR

Issamou,

Can you show me your project settings? I am running into an issue where I package using Support armv7 and Support arm64 is failing to build. Would you please upload the logs from your device when you’re installing the project onto your phone?

  • Attach your phone to the computer
  • Go here: C:\NVPACK\android-sdk-windows\tools
  • Open up Monitor.bat
  • Launch the program and save the logs

If you cannot get Monitor.bat to open, please go to:

  • C:\NVPACK\android-sdk-windows\tools\lib\monitor-x86
  • Open up Monitor.exe
  • Follow the instructions above

Make sure that you highlight all of the logs, because they do not save unless they’re highlighted.

Thank you!

Hey Issamou,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

Hey,

The problem was installing an arm64 app on an armv7 device that’s why it didn’t show up.

It seems that developing 32bits apps for VR doesn’t really harm the performance so I chose to deploy my app to armv7 ( 32 bits ) instead of arm64 ( 64 bits ) and it did package and install successfully on the galaxy note 4.

Sorry for the late reply and thanks for your support !