Ambient Occlusion not working (movable lights)

Hi,

 I have multiple scenes where ambient occlusion does not seem to be working despite enabling all the features that it seems to need to work. I haven't ran into the issue before.  4.27.1, rtx280super

-All movable lights
-distant fields enabled in preferences, and generate distance fields on imported assets enabled
-I can see the distant field AO in the visualizer by itself, but not apparent in lit mode
-BUT, if I view lighting components>ambient occlusion, on or off makes no visible change, which makes me think its not working at all

So with everything enabled, I see no effect when I adjust AO settings on the skylight or the post process where its enabled.

Please help, any info would be appreciated. The only other topic I saw on this with any resolve was the person creating a new project totally. Can I force enable in the command somehow?

That happened to me once… Until I figured out that I was in detailed lighting mode… :joy:

Haha, well I did check that, so its not the issue…but good to check, sometimes its something that simple. :sweat_smile:

Maybe u can share your setting for your skylight and postprocessing, and we can have a lookđź‘Ť

so I’m using dynamic lights, settings are somewhat similar (dfao, movable lights etc.)
try to uncheck “Allow Static Lighting” in the project settings. That worked for me.

Thanks! I will try it…but I probably cant use this solution because one of 6 maps in my project needs baked lighting, the other 5 are movable lights.

All right. Found the issue.
Using unreal engine 4.27.2 .
I was also having the same problem, AO not working after all I added the post process volume and tweaking the intensity .

Then I opened another project where screen space global illumination in disabled from project settings and noticed there AO intensity tweaking is working. As soon as I enabled the Screen space global illumination, AO intensity stopped working.

Looks like tweaking AO from post process volume doesn’t work if you enable screen space global illumination.
If you want to tweak AO from post process volume, Just disable SSGI from project settings.

1 Like

that’s odd. I can’t find screen space gi in the project settings.
where the heck is it?

AO doesn’t work either in my project. Trying to disable the SSGI, but can’t even find it in the project settings. Was this removed with 5.03?

I mean… it looks like, you can’t have both. You can have either Lumen, or SSGI, or Ray Traced. Back in the days, you could add SSGI.

In UE5 you need search for the keyword Global illumination. Then in that section there will be 4 in dropdown,
-Lumen
-screen space global illumination
-Ray traced(depcricated)
and none.

It may be no the same issue, but if you arrived to this topic thru the title " Ambient Occlusion not working (movable lights)" because your HDRI backdrop and/or Skylight is not showing proper AO. You should set it to Static or Stationary, you will definitely have a better AO.