Ambient Occlusion not working (in two places)

So, I’m trying to set up Ambient Occlusion in my scene, but I’m having a bit of a problem - it’s not rendering. At all. The odd thing is that the buffer visualisation for Ambient Occlusion shows nicely calculated AO, but then completely fails to apply it to the scene. I have no precomputed lighting in my scene (force no precomputed lighting is on, as it is primarily dynamically lit), but it doesn’t seem to help if I change my lighting to being precomputed. It seems like it would be a simple task to bake the AO map onto the diffuse texture, as it has already rendered it (as seen by the fact that the buffer visualisation shows it correctly), but it doesn’t seem to be having any effect.

On another note, my Material Ambient Occlusion map is stubbornly empty, despite the fact that I have several materials with an input to the Ambient Occlusion section. I have no idea why this would be, either, but I can’t help but think the two issues are related.

Can anyone help me work out how to actually apply the AO that has been calculated in the buffer?

So, I have a hacky work-around which uses a custom Post-Process material to grab the AO map and apply it directly to the screen. This works, but looks a little ugly in places. I’d like to know how I can do this properly, if at all.

Hey Hoeloe -

Have you gone into your project’s World Settings under Lightmass and toggled Use Ambient Occlusion on? (under Lightmass >>Lightmass Settings) You would need to use Lightmass, so the Forced no Precomputed should be false (unchecked).

Thank You

Eric Ketchum

Yes, but note that I am not using lightmass for my lighting calculations. However, even when I do, the AO does not appear.

Well, my workaround more or less works (with some reasonably complex tweaks), but I’m still wondering why, even when I turn lightmass on, my Material Ambient Occlusion buffer remains solid white, despite having my Ambient Occlusion node in my material connected.