Alpha texture not showing

I made a texture with alpha channel in photoshop and imported it to ue4. Then i made material with alpha channel connected to the opacity mask and blend mode to masked. It works with objects from unreal engine like cube and cylinder. But doesn´t work with object from blender which have a simple animation rotating around z axis. In fact, none of textures with alpha channel work with that object.

Hello joice000,

From what you have described you have a material set up with an alpha channel. You have that channel plugged into your opacity mask.

After applying this material to a skeletal mesh then you see nothing inside of your preview.

I recreated what I believe to be your steps and came up with this result.

There is an area on your material that I would like for you to check and see if it is enabled. In your details panel of your material scroll down to the usage section. There is a box that enables this to be used with Skeletal Mesh. Please make sure that this is enabled.

If you are still experiencing this issue then I will attempt to recreate this with a controlled test project. For this I will need your .uproject, content, and config folders for your project.

Let me know if this fixes the problem.

Thank you,

Hello joice000,

I haven’t heard from you yet. I was wondering if you were still experiencing this issue or had a chance to take a look at some of the troubleshoots mentioned above?

Thank you,


Glad I could help.

Sorry i was not able to answer. I Changed a mesh from blender with simple cube which came with UE4. And now all just work fine.