Download

Alpha channel

How to enable alpha channel in UE4?
I imported a model from 3ds Max to UE4, everything is fine except for transparent textures displayed .
Long searched for how to fix - find just what you need in the drop-down menu to include an alpha channel.
cf9738882d8399e83c5dbeccc8c0486b0008bff7.jpeg
Turn , save - and nothing , transparency does not appear.
68e6db76359a62c4fb5745ecb05b6cda77cd7b3f.jpeg
Here’s how it looks in UE4
b47ace9f18fd0c3d40b084fc804cdbd53a04f874.png
But should look like (screenshot from 3ds max)
b4f9c1d47eff68c1e8b0c23ef5ada32e7552f3d6.png
The editor sees that there is an alpha channel and even apply it correctly ( I turn the alpha menu ) - but do not store the result in the material and model .
Translated by Google.

What shall I do to the alpha channel work?

Disable Red, Green and Blue in texture viewer and see if Alpha only shows you a black and white image. If not, then you’ll need to go back to your texture editing software(Photoshop or Gimp), make sure the alpha channel exists and then save it as 32bit TGA; then reimport.

c08fa86bc6bb84a339c5ef9ba3565935266521b5.png
Himself an alpha channel is present in the TGA - and perfectly displays in 3ds max as the fourth image first post

In the viewer displays all right , but on stage , nothing changes .

The material you showed is not a translucent material. Change the mode from Opaque to Translucent (in the details shown when you select the output node of the material). You will also have to wire in the fourth output of the texture sample node to the Opacity input on the result node.

Cheers,
Michael Noland

Thank U!
Now everything works as expected .