Alot of spline meshes cause massive framerate drops


I have a lot of spline meshes in my scene (around 125+), every mesh has low polygon count ( 21 tris ).
I looked up everywhere and did everything that people said.

  1. Make sure that it is set to static and not movable.
  2. also checked to make sure it dosen’t have collision (checked don’t need it)

But I still suffer from massive framerate drops.
Please helps.

Interesting, with around 400 movable spline meshes @ 96 tris each and with a double sided translucent material I see absolutely no impact on performance whatsoever. And my PC is average by today’s standards.

The only time when I can observe a hit to the fps is when I update the splines every frame. Are you doing something to the spline and the spline meshes during Tick?

Nope, do you have 400 splines mesh directly in the angle of the viewport?

Nope, do you have 400 splines mesh
directly in the angle of the viewport?

I just gave it a quick test, with 13 objects, 36 spline meshes each (468 SMs in total / 96tris each / 2-sided, additive material).

If they’re not being updated my fps sits around 270 whether I see them or not (yes, all of them - never noticed any impact). When everything starts moving during a Timeline sequence - the spline points are redistributed, the tangents recalculated and SMs reshaped, I lose around 20% - quite a big impact, yes but I’ve done no optimisation here yet.

edit: To give you a rough idea of what I’m talking about, the concentric circles here are the splines with their own respective SMs:

They are created dynamically at the beginning of the game. Previously I tried spawning them completely on the go but that brought everything to its knees. Instead, they are now alive all the time and either sit pretty or stay hidden.

While measuring everything in FPS is not really healthy and I should have given you ms, it does paint a half-decent picture of things working rather smoothly.

My question to you is: are you doing something to the spline meshes during tick, as in constantly updating / respawning them? Perhaps you’re hitting the limits of your PC’s performance. My machine has a fairly old GPU - 7970 and the second gen quad core. However, if you’re trying to do it on a laptop, I can easily see it impacting performance quite dramatically.

In my case it was the ShadowDepths that was killing the performance.

Hi I’m having the same problem, have you figured it out?

Check the material shadows off (it’s sounding odd, but it is in the raw mesh’s options). It won’t solve the entire number of the possibly related problems, but it’s one of the most that may cause the impact.

Thanks, but I can’t see any improvement :frowning:

You can enable simple collision for mesh that you use for spline mesh. Sometimes such collision will not be very accurate, but the performance will increase very much.