All my new added BSP go invisible?


When i try to copy a existing BSP or try to add a new BSP for the modes list they go invisible, i tried to restart the program and turned on and off the show BSP but it wont work please help

Sorry for the bad piture.

Hi ,

In your bsp menu, make sure you are using additive, not subtractive brushes. Subtractive brushes will appear as you are seeing, but are used to subtract from other bsp geometry instead of add new geometry to the level. Does this fix the issue you are seeing? If not please let me know and we’ll continue.

its on additive and i tried to make it subtractive then additive and that did not fix it. you mean the two buttons under BSP?

Yes, if that is the case, try building geometry by pressing “build”. How many bsps do you have in the level?

when i press build i can see the BSP but when i move them they go invisible and my whole level is made of BSP so 170-200 or so.

Go into your Edit>Editor Preferences>Miscellaneous, is “Update BSP Automatically” checked to true? If not this may be what is causing what you are seeing as you have to build each time you move or change a BSP to see the updates. Checking this to true should alleviate that.

its on true

Ok, next step is to open a clean, blank project with no additional content, then place a bsp, do you see this occur? Additionally can you post a copy of your dxdiag so I can take a look at it?

in the blank project it work.

sorry i cant find dxdiag p.s im on windows 10 if you like to know.

Try the steps listed here to get your dxdiag:

link text

I’ve been trying to reproduce this on my end but thus far have been unsuccessful. Can you send me a copy of the project you are seeing this in? I might be able to determine what the cause of the error is.

do you want the whole folder or only the level?

The whole project would be best so I can see everything that could be causing this to occur.

its to big to send so what files do you want the level and what more?

How big is the project? Did you try zipping it into a . folder?

If this doesn’t work, just send the .umap and I will try to see if that works, if it doesn’t we’ll have to find a way to transfer the whole project for me to be able to continue testing.

link text

the first was 11 gb

That is the .uproject. If you go to your contents folder your .umap should be somewhere within the content folder filepath, most likely in the “maps” folder.