All materials are blurred in imported meshes

Hi there. First time poster here and new user to UE4. loving it so far, though admittedly frustrated.

So I have attached a photo of a scene i am working on. The geometry I created in Rhino 5, exported to 3dsmax, and then exported into UE4 via FBX. (When i tried rhino into Ue4 it would always hang at 75%).

Anyway, when I add materials to my mesh sections, it comes up blurry every time. Is this a UV mapping issue? I am terribly confused, because when I drop in a cube from the UE4 basic tab, or a bsp brush, and add the same material, it comes up fine, as a plank of wood for example… Though it happens with all materials. The brown section below the point light is the same material applied.

The rest of the materials in the scene are from the automotive materials pack.

Any solution to this? Am I importing incorrectly perhaps?

try importing as an obj I usually have an easier time getting my assets into UE4 that way but if that doesn’t work and you’re still getting the same problem your uv’s are messed up maybe upload a couple images of your uvs and the meshes you’re trying to apply this material too. try the OBJ import and if that doesn’t work post a picture of your uv’s and wire frame.

Thanks for the reply! I have tried importing an OBJ, same results unforutately.

I’ve included a pic of the wireframe, but how do i show you the UV’s?

Apologies if thats a dumb question

It’s most definitely a uv problem your uv’s may be inversed or the mesh you’re using doesn’t match your uv map. Open your mesh in max and open your uv editor and take a screen shot then also send screen shots of any maps you’re using(Normals, AO, Rough/Spec, Color). I’ve had this happen to a mesh before where I changed my pivot point and didn’t redo my uv’s could be a really simple fix will know more once you get the screen shots. On the bright side your geo is really nice!

This explains it all: