Aja output not functioning in new plugin

Does anybody know what is the upper left corner overlay with this strange “square counters”? It seems like some valuable content (maybe UE embeds something there for help AJA to sync video?). What it does?

It seems some kind of signaling but is nothing that I’ve ever previously seen (WSS, AFD, etc). It will be always there? Any plans of moving this into a less visible place?


They added a debug option to “burn” the time code. You can deactivate in the AjaMediaSource or AjaMediaOutput.

And how it can be used? Are they white pixels moving from 0 to 9 indicating each number of the current TC in each row? HH:SS:MM:FF represented as 8 rows x 9 columns? Is this any kind of standard representation of TCs?

Do you have any idea how the HDMI out port functions from within UE4? I seem unable to monitor an outgoing feed from the editor.

Can you explain in more detail how you did this? I hope to have teaching. Thank you.:slight_smile:

There aren’t many things to explain, the plugin works but in my particular case the options available regarding the different video formats are not all listed.

Following the guides under https://docs.unrealengine.com/en-us/Engine/ProVideoIO would be pretty straightforward, and here in this post you could also find nice tips to find where to look if anything goes wrong.

Once comfortable with the setup, if you need to use a different video format not listed under your AJA port settings you can paste directly the “port information” and set a different resolution/framerate. For example if you want to set the video format to 1080@50i you can just copy this text:

(DeviceIndex=0,ModeName=“1080i 50.00”,FrameRate=(Numerator=25,Denominator=1),TargetSize=(X=1920,Y=1080),VideoFormatIndex=1)

And right mouse button and paste over the Port you want to set, here you have a screenshot of that paste operation

If you can be more specific maybe I can give you more detail about it. What do you want to know? dealing with the second output with that alpha key video? dealing with interlaced video?

Thank you.I have got the effect!~~. But I don’t know why I have to move the AJA port 1 every time and then execute the undo before it will display correctly on the display. Otherwise, it will show the out of range. It will be normal after undo.

(DeviceIndex=0,ModeName=“1080i 59.94”,FrameRate=(Numerator=30000,Denominator=1001),TargetSize=(X=1920,Y=1080),VideoFormatIndex=2)

I have solved the error, thank you!!~~

Do you know how the black and white blocks displayed by the key port are displayed in reverse? White becomes black, black turns white.


Hi everyone.
I have another problem with the AJA plugin.
In the UE Editor, everything I want from AJA plugin is perfect.

But when I want to package my project to exe file, I checked that my project cannot display video input in my level in my program(which I packaged by UE4).

When I package my project, I have see the message:
UATHelper: Packaging (Windows (64-bit)): LogInit: Display: -----------------------------------
UATHelper: Packaging (Windows (64-bit)): LogInit: Display: LogAjaMedia: Warning: The AjaMediaPlayer can’t open URL ’ [aja://device0/port1]’ because Aja card cannot be used. Are you in a Commandlet? You may override this behavior by launching with -ForceAjaUsage
UATHelper: Packaging (Windows (64-bit)): LogInit: Display: LogAudio: Warning: Warning: SynthComponent failed to start due to failiure in initialization
I just see above the image.

So, the plugin just run only on Editor mode? What am I doing wrong???
Pls give me some advices.
Thank you so much.

You have that message because we have the editor opened and another instance in the background that build the package files. Both are trying to get access to the AJA card and only once access is authorized. We do have AJA running in standalone. (When there is no UE4 background process running).

Thank you for your answer.
I tried to package my project by using ue4 ( I used command, buildUAT.bat). After I packaged my project, i have a exe file. The exe file is run ok but I cannot see the video feed(which set in aja port1). It like the second image above.

My problem that: When I have exe file (or Lauch game in UE4 Editor, not Play), i cannot see the video feed on its. I sure that I can see the video feed in Editor mode.
Do you ever meet it before? What next can I do to fix that?
Thank you so much.

Before trying with packaged game, have you tried in -game first? Packaged and -game work for us.
Do you have anything in the log that could help you?

Before trying with packaged game, have you tried in -game first? Packaged and -game work for us.
Do you have anything in the log that could help you?

Dear Mr BêCCLE.
I have use mediabunder which has setup aja port to show video feed.
I have tried -game parameter for test but it display nothing, just like the second image. Could I send to you my project for you via your email? I realy need to your help for my problem.
Thank you so much.

This is my simple test for package UE4 project which has used Aja input.
I still see nothing when I run --game( and lauch or packaged).
I just see video feed only in Editor mode.
Pls check what I am wrong.
Thank you.
link text

This is message when I run “Lauch game”
"[2019.05.17-03.02.44:215][767]LogAjaMedia: Error: Device: Try to enable the channel ‘1’ on device ‘Kona4 - 0’ as the owner but it’s that was already enabled. Do you already have a ‘input’ running on the same channel?

Then, something else is running with AJA on your machine. You can check in the AJA control panel who has the ownership.

Hello everyone!

Since this is the most populated thread with lot’s of explanation. I hoped you could help me!

I’ve installed AJA Media Player plugin, but there is no “AJA Media” option in Project Settings → Plugins.

I’m trying to make AJA Kona LHi work, but can’t even set it anythere in UE.

I’m using Unreal Engine 4.22.3 and latest “AJA Media Player” plugin.

What am I doing wrong?