Aja output not functioning in new plugin

I am using the new AJA plug-in and am unable to get output from the card. Unreal only seems to be recognizing Port 1 and 2 for input, so I am getting a good input feed. However, Port 3 and 4 seem to not be recognized and are not sending data out. I have tried the studio example where I am facing the same issue, and have loaded up AJA Control Room where the card was outputting video feed through Port 3 and 4 normally. Any help is appreciated.

Hello,

The plugin only supports 4K Mode Firmware.

Which KONA card are you using?

For Posterity: Check the Output log for any AJA warnings/errors. Your input may be @ 23.98fps, but it must be at 24.

Could you help me: how to use the AJA plugin in UE 4.20 to render SDI output with KONA card?
Espcial, how to config/do to show the output SDI from the card in UE.
Please!

Does the current implementation only support 24P, or are all HD SDI & UHD (4K) formats supported?

I am experiencing the same issue using the Corvid 88 card, UE4.20.1 not showing any SDI output. I have not tested input yet, and I do not have a 4K monitor, so I am limited to all HD SDI formats.

Also, I updated to the latest firmware & drivers from AJA (images attached).

AJA Control Panel Video Ouput works showing all test patterns on SDI 3 output. Tested various formats to confirm card is working ok, and using card with other broadcast solutions. This is in a HP Z820, Windows 10, nVidia Quadro K6000.

Thanks in advance for your help.

  1. Check the log for errors
  2. In 4.20 we support interlaced and progressive. PSF is not supported. We support HD format. (2k and 4k are on the official roadmap)
  3. Only Single link 3G. Dual-link and quad-link are not supported (they are on the official roadmap). Format B is not supported.
  4. Corvid and Kona 4k are tested.
  5. Support input (use AjaMediaSource and regular media framework) and output (use AjaMediaOutput and the new MediaCapture. In BP, AjaMediaOutput.CreateMediaCapture).
    5.1 Known bug, if you output via MediaCapture on the first frame of your game, the resolution will not match, try to wait for 1 frame before outputting.
    5.2 You can use the MediaCapture tab available in the MediaFrameworkUtilitites to help you output in the editor.
  6. Input 8bits and output 8bits (10bits coming in 4.21)
  7. You can output a scene viewport or a render target. The texture size and pixel format need to match exactly.
  8. Interlaced is supported but we do not de-interlaced it. We use the half frame. Unreal takes each field and scale it to the full resolution on the GPU. It will render at twice the speed of the frame rate. (1080i30fps. Unreal will have 60 half images per seconds and run at 60fps to show them all).
  9. Talk to us first. Only contact AJA if you have a problem with your hardware (like if it’s on fire and you need a replacement).
  10. You can read timecode when embedded in a video. You can use AjaTimecodeProvider. Better support coming in 4.21
  11. The engine can be genlocked with the AJA card. Create a blueprint AjaCustomTimeStep. Set the media mode. Change the project settings (engine->general settings->custom time step) Restart UE4. Genlock will have a better support in 4.21(support for reference in). In 4.20, the engine will be updated when an image is received. Ideal to sync the engine with your video.
  12. Have you heard of MediaBundle? It’s an easy way to create a media in your map.
  13. Aja can auto-detect the video format. UE4 does not. It’s a design decision.

Dear Mr Alex O.
I must have a long time to see your guide. It is great and you too!!!
I am at home and I will do as you said on tomorrow.
Thank you a million.

Dear Mr Alex.
I have read your guides and I did with my Kona 4 card. I tested again the input and output before use/config my card in UE 4.20.

But I still get nothing from the AJA plugin (AjaMediaOutput). So I attached my BP, my config in this file.
Pls check that what I wrong.
Thank you so much.

[setting Kona 4 card and setting the AJA Plguin][2]

You need to tell the media output what to output. You can output a Render Target 2D or the scene viewport. What you output need to be of the same size and same pixel format as specified in the AJA Media Output.
The “Active Scene Viewport” will be accessible in “New Editor Window (PIE)”, standalone game or cook game.
The pixel format of the scene viewport is defined in the project settings, Engine->Rendering->Frame Buffer Pixel Format.

You are strongest, my man.
Thank you so much. I have done!

Hey guys I’m trying to figure out how to Capture the Kona4k into unreal and also display the capture as my view port background. Do you guys have any tips on how to achieve this?

Trying to get UE4 running as a realtime virtual studio. Do you every try to output an separate key channel to another SDI port? wondering how to archive that…
I’ve seen since 4.17 there’s a alpha channel in post processing. is it archived by compositing inside UE4 and output a final image with Background and Foreground with the realtime SDI feed in middle?

The option is available in AjaMediaOutput. Use the “Key and Fill” option.

Hi,
Same as DJ.penguin, I tried to output Key and Fill, and no success by now.
I choose option “Key and Fill” as BeCeCLE PmB advises, but no luck.
KONA4 port 3 displays perfect Fill image. No key image from port 4.
I setup SDI output (port3 & 4) as Fill & Key mode in Aja control panel.
I am wondering right Key & Fill setup with Aja KONA 4.

Check your log. Usually, there’re warnings or errors explaining the issue! We may have to enable the alpha channel support in post-processing to enabled the key. I think the alpha information is not collected by default.

Ok, Thanks alot! I will have my hands on the cards by tomorrow. and doing tests soon.

Thank you so much.
I am just thinking how to enable alpha in post processing of UE4.
Could you tell me how to enable in the Manual or link?
I feel I stuck there.

Moto-man, seems we stoped at same point. I’ve checked there’s a parameter to enable alpha in material. but only if that material is in post processing domain.
same to you ,still woking on how to assign alpha channel to objects…

Hi DJ.penguin, I am facing same situation and cannot get alpha channel even enabled in post processing setting. If it is OS matter, I upgrade to Windows10. I will let you know as I see progress.