AI Perception Sight not showing in Debugger

Hello there,

I think I might run into a bug regarding the Gameplay Debugger and perception component. I’ve only tested it with AI Sight, using the Third Person Blueprint, in 4.12 doesn’t show. I’ve also tested functionality and it works fine, just doesn’t show on the debugger. Any ideas?

4.12 Preview 4


Hello Luke,

I have been able to reproduce this issue, and have entered a bug report, UE-31090. Thank you for your report.

Have a great day

Good to know!
Thanks Sean!

Still down in 4.14.3 as far as I can tell

I’ve tested this in 4.14.3 and it seems to be working on my end. Could you provide more context on your setup? A detailed list of steps to reproduce your issue would be great.

Have a great day

This issue has been resolved as of 4.12. Perception is not located in the Editor Preferences, as it is not an experimental feature. You’ll need to add an AI Perception component to your AI Controller, and configure your perception settings on that component. Then, you’ll need to add AI Perception stimuli source components to all actors that you want to be able to be sensed by the AI Character. Keep in mind that pawns are registered as sources by default.

Have a great day

Still no news? I m on 4.15.1!
Maybe someone can explain how to activate it? i can’t find perception in the Editor Preferences…

Hey Sean, thanks for reply :slight_smile:
I’m sorry for that bad english… i meant that i want to see the sight and hear area in the viewport for bug fixing. Is it possible? i see “how to show ai perception area” youtube videos but the tutorials seemed not be up to date.

To show the debugger, you need to press the apostrophe key and then press 4 on your NumPad in order to display the perception debugging.

Here’s the documentation: Gameplay Debugger | Unreal Engine Documentation

Have a great day

1 Like

I can’t make it work in PIE in 4.15.1
In Simulate it works fine

Hey Zikoko,

I gave this a shot on my end and it seems to be working. Would you mind providing a video of this behavior so I can have a closer look to see what could be going wrong?


Hey Sean L,
I have the problem that sometimes the debug visuals show up but most of the times they don’t. I have to start and stop play constantly and maybe 1 in 10 times the debug visuals show up. I recorded a video to show when it does not show up: UE 4.19 - AI Perception not showing in Debugger - YouTube

As you can see I’m toggling the EQS and Perception options with my numpad but nothing is showing. The AI to the left has the AI Perception sight sense and sometimes I can see the radius of it’s sight but most of the times not. Here is another run when everything is working: UE 4.19 - AI Perception sight is never lost - YouTube

It has been like that for me for several versions already but with the latest it seems worse. Before I got it to show up like every second or third time.

Hi zaha,

If you believe that this is a bug, please report it using our new Bug Submission Form and we’ll follow up.



I found out what’s happening. If you close the Debug tool with apostrophe, then press 4 on the num pad, then press apostrophe again to reopen the debug tool, then press 4 on the num pad again, it will work. I believe what is happening is that there is a flip flop or a bool that tells the debug tool whether AI perception is open on the back end but there’s no if statement in front of the 4 key on the num pad saying “only recognize the 4 key input on the num pad when the debug tool is open”.

To simply fix your AI debug tool issue:

  1. Close Debug tool by pressing apostrophe.
  2. Press 4 on the num pad while debug tool is NOT open.
  3. Open debug tool by pressing apostrophe.
  4. Press 4 on the num pad while debug tool IS open.
    This fixed my issue. To break it again (not that you want to), press 4 on the num pad while the debug tool is off.

still an issue 6 ■■■■■■■ years later

1 Like

Go into project settings then gameplay debugger and then change “apostrophe” to ’ for example.


Just found this issue on 4.25, i had to press " ’ " and 4 several times before it worked, not sure if it’s fixed in later versions.

1 Like

still relevants to this day!

Yes, they didn’t change much in that regard.

Still an issue in 5.2. Seems hit and miss, just toggling ' until finally the list populates. Toggle once too many and its empty. Any better workaround anyone?