AI Pawn velocity is huge compared to player velocity

Hey everyone,

I noticed that projectiles of my AI controlled pawns seem to be spawned way in front of the actor. When debugging, I found out that the velocity (which I add to the spawned projectile) is insanely large for the AI pawns, whereas for the player the velocity is in the range of the max speed. I use the same base class and movement component for both actors.

The only difference is that one is controlled by a player controller and the other by an AI controller that runs a Behaviour Tree. I am out of ideas what might cause this. Does anyone have an idea why the AI’s velocity is so large?

I have attached two screenshots taken during play from both actors:

AI Pawn




Same problem here,
You’ve figured out why?

Ok i’ve solved the problem.

To avoid this issue you have to set Use Acceleration for Paths inside the Nav Movement section.
In this way the AI will use the speed data from Component to set velocity instead set it directly.

However this will cause another possible issue. the AI will slow down when is near to the target because the logic of movement in FloatingPawnMovement.

To avoid this is also necessary to set the Use Fixed Braking Distance for Paths.

This will take the param inside Fixed Path Braking Distance and start to slow down the AI when he reach the distance inside the param.

If is set to 0 the AI will not slow down the movement untill he reach the target.

Here an example Pic about the correct params settings


I hope this will help everyone who needs this.


Awesome, thanks for sharing!
I’ll try it as soon as I can.

thank you so much. I spent hours trying to fix this.