AI Navigation Works on Development Build but Not Shipping

Enemies doesn’t start walking after spawning when running on a build packaged with the Shipping configuration.
It works perfectly however when running the game from the editor or on a packaged Development build.

What can be the issue here? What are we missing in the Shipping build vs. Development build?
Can it be something entirely else not relating to navmeshes?

I’ve tried these options without any luck:

-Force Rebuild on Load

-Dynamic Runtime Generation

-Placing the navmesh in either the persistent level or the sublevel and also placing it in both levels

-Deleting all navmeshes and recast and placing them in the level again

I’m hitting a similar issue, were you ever able to find a solution?

I’m with a similar issue as well, was able to pinpoint to the behavior tree key value that by some reason does not get set in the packaged build.
Mine does not work on shipping and development.
I can find a work around for that with class calls in my case, will try later.

Alright, the issue was at one of the blackboard values not being set in the packaged build.
I simply added a class call and got the value in the BTT/BTS when spawned, set it there and it worked fine.
Now mine works in development/shipping settings as well.
After further investigation, any “get value” from the blackboard does not work in build/ship, so consider changing the approach to these values.

No problem! Blackboards does works, just the “get blackboard value as…” apparently does not works.
A good tutorial for AIs is this one: Introduction to AI and Navigation Systems in Unreal Engine | Pluralsight
There are others too, but this one gave me the basic understanding to expand it as I needed.

Interesting, thanks! So blackboards don’t work in production? I find that hard to believe. By any chance is it a multiplayer game and you’re trying to access the blackboard on client? I think that’s part of my problem or at least has been where I’ve been finding issues. Honestly I’m really not sure what a blackboard is good for that a dictionary/hashmap on the controller couldn’t have done. Has overcomplicated my project’s AI. I guess blackboards handle events and stuff too, which a map wouldn’t necessarily, so maybe that’s the big sell. Still… In any case, thank you for your reply!

Same problem, BB value came back null/none on packing. working perfectly fine in editor.

We’ve been reworking a lot and cleaning out some stuff during the project and now it suddenly works. Unfortunately we haven’t been able to pinpoint what it was that actually caused the issue. We’ve updated to 4.18 and that might also have contributed to getting it working again.

For us, ProjectPointToNavigation does not work in a packaged build. Did you, by any chance, use that one?

Hi. I had the same problem, but i fix it. Just changed in the World settings the Navigation System Config to be Navigation System Modules Config.