AI Move To Actor stop & go in 4.12, OK in 4.11

I’ve verified this with a new 3rd person project in both 4.11 and 4.12

Start a 3rd person project, no extras but with the starting pawn and staircase

Make a duplicate of the ThirdPersonCharacter BP (default name ThirdPersonCharacter2)

Drag the BP to the scene so you have a second pawn

Edit the ThirdPersonCharacter2 BP, add PawnSensing, default is fine, or you can give it 180 degree vision

In the event graph of ThirdPersonCharacter2, add an Event:OnSee and have it MoveToLocationOrActor to the pawn it sees – turn off “Use Pathfinding” so no NavMesh needs to be made

Run in the editor and compare 4.11 to 4.12

4.11 runs as expected – the following pawn just runs after you, and can keep up

4.12 does a momentary stop every .5 seconds (or whatever the Sensing Interval is set to), which has it noticably stop, and makes it lose ground over time

Same behavior in the compiled versions under MAC OS X


Could you provide a screenshot of your blueprint, as well as your Pawn Sensing settings? I have been unable to reproduce this issue on my end.

Here’s the follow:

The pawn sensing is all default:

If you can’t see any difference, set the Sensing Interval to .1 seconds and it’s very obvious.

This is on a mac, it’s possible the PC version doesn’t do this. 4.11 on a mac works fine.

Also note that I have “use pathfinding” turned off, so I don’t need a navmesh.


I have reproduced your issue, and have entered a bug report, UE-31825. Thank you for your report.

Have a great day

There are some code bugs there, but you’re setup adding to the whole situation as well. {{OnSeePawn}} is called every frame if the pawn is in sight, meaning you retrigger move code every frame, which is very inefficient and spammy. Move to actor will automatically update path if goal actor moves, so there’s no point in spamming the request.

It said it would be fixed by UE4 13.1 Unreal Engine Issues and Bug Tracker (UE-35852)

still broken.

Mine’s still broken after upgrading to 13.1

Hey tatzel,

That’s actually a slightly different issue. The issue you’re looking for is here: Unreal Engine Issues and Bug Tracker (UE-31825)

This issue has not yet been resolved, which is why you’re still experiencing it in 4.13.1.

Have a great day

That bug said it was happening in 4.12… My AI was fine in 4.12.5 but upgrading to 4.13, AI Move To stopped working. Also the workaround (I haven’t tested) in 4.13.1 makes sure the velocity isn’t zeroed so I don’t think it’s fixed… UE-35852 AI Move To Location zeros velocity each call NOT FIXED! - Feedback for Unreal Engine team - Unreal Engine Forums!

Hey AlexDiru,

I’ve tested the repro fro UE-35852, and it appears to be fixed on my end. Could you provide some screenshots of your setup so I can see if you’re doing something different that could be causing the issue?


“AI Move To”-node still not working in 4.13.1.

Mine stopped working in 4.13 and they said it’s a bug that will get fixed in 4.13.1 and now I see “AI Move To FIXED” posts but mine hasn’t worked after 4.13 came out.

Here’s a picture of the node that hits FAIL every tick and keep in mind that this all worked fine before.

The issue has actually been reopened, and it has been noted that it is still occurring.

Thanks for letting us know!

hi, the issue is still occurring.The EPathFollowingResult is always aborted. UE4.14.2

Hi ChenChen,

I’ve tested the original repro for this issue and it’s fixed on my end, so it’s possible that you’re experiencing a different issue altogether.

Go ahead and create a new thread in the Bug Reports section, and provide repro steps so that we can reproduce the issue on our end.


This definetly fixed it for me… while using other Move To Nodes, you can have it run on event tick without a problem but when using Move to Location or Actor you only need to run it once since the AI will automatically update the actor’s location without the need for an event tick(the event tick will make it run over and over again causing the stutter)…