AI gets stuck on NavMesh Corners/Ends

Whenever my AI character hits the ends of a navmesh bounds volume they just get stuck there and completely lose the ability to randomly walk around. I tried placing invisible walls/normal walls but it seems like its an issue with the engine that it throws the AI out of the bounds area.

If you look at my image that I attached you can see my Shark is just outside the bounds volume after it randomly wanders there. I also posted my wandering BP code as well which is nothing fancy or complex.

Any help would really be appreciated.


Similar problems people had with this…

1 Like


Have you tried adjusting the Agent Radius as mentioned in the post you linked?
You can do this in Edit->Project Settings->Navigation Mesh.

Thank you for replying back, I would like to show you one other image just for clarity sake and also for others that search this. Once again my character is stuck just on the outside.

What is a good number to set this too? down or up? What do you use for AI? Once the radius is set (whatever number that is) what other methods should I use to avoid other nav mesh pitfalls? If you don’t know thats okay i figured the more info out there the better.

Thanks again!

…Yeah this definitively does not work, spent the last hour messing with this and this shouldn’t be so hard, I just want my guy not to get stuck.

I found another thread on here with the EXACT issue I have and his solution does not work for me.

-I adjusted the radius agent to many different numbers (34,8,etc…), no luck.

-I made a Supported Agent under the navigation system and re-made the nav mesh. no luck still gets stuck on corners.

I apologize for the delay.

I have an additional suggestion as well. If you’re using a character class, go into the Character Movement component’s settings and adjust the Nav Agent Radius in there (if you have not already). If you are using a pawn you can also go into the Floating Pawn Movement component and do the same.

I know you adjusted it in the Navigation Mesh settings but I wasn’t sure if you’ve also adjusted the property in your character itself. As far as values go, this is something you’d have to play with as it depends on your setup.

If you’d like to provide your project, you can zip it up, upload it to Dropbox and provide me with a link through PM on the forums: and I can take a closer look. It will be difficult for me to determine the exact cause of the issue without taking a look at the full setup.

Thank you


Thank you for helping me troubleshoot this issue, good news is I have figured it out. The solution was to delete a collision sphere on my AI blueprint that was causing this error. When I did this the BP I posted above no longer really works because I had to increase the Radius on the get Random node as well as place a delay after the event tick so he doesn’t bug out and has time to walk there. Now he never gets stuck, its awesome!

I wanted to figure why this was happening and if I could reproduce this so I went ahead and duplicated my AI and deleted everything but the corrupted capsule and my mesh character. It still caused the error and not only that it made my character move in the same slow motion kind of way like before. that’s why if you tried my BP originally from a clean slate it does not work smoothly yet on this instance it does.

I even deleted and re-created the sphere with the same exact settings inside details as the corrupted one and it was working fine.

I’m taking this down as a strange glitch, I posted another AI pic for anyone else, basically collision spheres was my issue so delete those and see if it works with no NAV agents or any project settings just a NAV mesh and character movement and it should work, no getting stuck.

Onward to more development!