AI Following Player Stops During Double Jumps

Hey all, first time posting so bear with me.

I’m working off the First Person template and I’m having an issue with an AI enemy following the player. The AI follows the player just fine, however once I double jump (Blueprints below) the AI stands perfectly still until you land. Once you land the AI continues following you (See example

Double Jump blueprint:


I’ve tried having the AI follow the player using two different methods, this tutorial for behavioral trees and the PawnSensing blueprint below. Both methods follow the player just fine, but again once you double jump it stops following until you land.


As a heads up, I can stand on a block higher than the double jump height with it still in the NavMesh and the scorpion will still attempt to get to me, so I’m not convinced this is a height issue. I’m not sure what’s causing this to happen, any input would be appreciated!

I also found out recently that this exact same issue happens if you use a rocket jump mechanic in my project. I though this had something to do with how the player was interacting with the NavMesh because of this, however I wasn’t able to go anywhere with this new information.

Quite possibly because the player leaves the nav mesh bounds. In a sense the AI has no path to target.

The NavMesh bounds was sized to be higher than the double jump height, and I can stand on a block that is higher than the double jump but still in the NavMesh and the enemy will still target you. Unless there’s something I’m missing with the NavMesh itself, I don’t think this is the issue.

Hi, if you use behavior trees, then the MoveTo command has a flag to allow incomplete paths. If you not allow that, then if it can’t reach the target, it will stop moving (had this with the player using jetpack). I don’t know though whether allowing incomplete paths is enabled by default if you use MoveTo like you do, or how you can even enable it (I only use behavior trees for such things).

Are you talking about the “Allow Partial Path” check box inside the MoveTo command? That was checked by default. Unchecking it didn’t correct the issue, as well as raising the Acceptable Radius.