AI fails to navigate when placed after Begin Play

I’m strugling with some navigation issues. I have a simple AI for a pawn that makes it follow some actors and flee from others, not a big deal. The thing is that when I place the pawn from the browser and load the level everything works perfectly, but when I spawn the pawn in game from a little menu I’ve made they only play the running animation but don’t move. I’ve tried to spawn the pawn from a different BP (the level one, witha 2s delay) to try if the issue was the menu, but it still doesn’t work. I’ve only changed the navigation options to make the Runtime Generation Dynamic, because I need it to accept physic objects moving arround (in case that might be the issue). I’ve also checked, and the pawns placed from the browser debug a valid path (when they are told to find a path), whereas the ones that are placed afterewards have the path as invalid always.

Ok, nevermind, I just found out that AI has to be set up to be possesed when spawned and placed in the world. I’ll leave it here in case anyone runs into the same problem.