AI Controller stopped working after 4.11 update

I have just updated my project from 4.10.14 to 4.11.0 as a test. My AI controller class has stopped working for some reason. Debugging has found that the main Tick function is no longer being called… Everything is still setup correctly, I believe.

Has anyone else encountered this?

Hello jamiewhitephd,

I can’t say that I’ve seen reports of this issue as of yet. Could you provide the code related to your AI Controller that isn’t working? It’s most likely either code or blueprint related so we’ll need some context to be able to help.

I managed to solve my problem, in the end.

For some reason, a couple of classes were missing a call to Super::BeginPlay() … which I believe tells the actor to enable ‘tick’? It was working fine when using 4.10.4, which is strange. Not sure what happened there, but something to watch out for in the future!

I solved my issue - see my answer :slight_smile:

This worked for me as well. Thanks!
I had neglected adding 'Super::BeginPlay()" to my AI Controller class method, Begin Play. Once added, the Tick function works!