After UE 5 update this morning all Nanite meshes are now only using fallback mesh. This is on all projects, even blank new ones. Help?

I had changed no settings of any kind, all had been working yesterday perfectly. I restored my project from git to be sure, and still any mesh converted to Nanite becomes only the very low quality fallback mesh. Blank new projects with default settings also have this issue. Any mesh ticked to Nanite will become a decimated useless low-poly stand in. I use the precompiled binary, not source. No mesh shows in Nanite visualization, they only appear in wireframe.

Is there some main compatibility settings I might be missing?

1 Like

Swithing RHI to DX12 appears to have resolved the issue

I changed to DX12, Nanite starting working and now I can’t see anything in Lit mode. Any ideas?

Same problem here. Nanite doesn’t work properly, no matter what you do, it just doesn’t work. Preview 2 worked fine.
EDIT: Ok, updating to Windows 10 build 18363.1350 seems to have finally resolved the issue. I have a material that no longer works with nanite, I’m looking at why.

1 Like

I have the same problem, you know… And I have the latest OS version. Any ideas?


Hi there, I have the same issue. I’ve tried everything, DirectX 12 is enabled, Windows updated. When I turn on Nanite, the object turns into a low poly version and the Nanite visualization doesn’t work, my screen gets a little darker when I activate it. I’ve been trying to resolve this for more than 4 days now, so frustrating… Any help will be deeply appreciated!

1 Like

I had the same issue and it wasn’t related to DX12 SM6 pr Material or Shader compatibility, it seems the project was stuck displaying the fallback mesh only.

My Fix: Go into editor preference and change the location of the derived data cache for both local and shared, this will then ask you to restart, once it restarts it will force a rebuild of the shaders and meshes, this should fix the meshes being stuck in its fallback state.