Download

Advanced Sessions Plugin

So when I get my appid, I will be able to see all the servers using my appid just by creating the advanced session and then finding it?

Yeah, you have to specifically add region locks to your own App ID.

Hi, mordentral, I’m using 4.12.5 and this plugin to get Steam user name. When launched in standalone mode, it works perfect, but after packaging, Get Player Name node always returns “Player”. I think I have packaged successfully, what anything else may go wrong?

Your steam subsystem isn’t working correctly, make sure you package it out with the project.

You can package in development mode and run the exe with -log to see the log during run.

The subsystems turned into plugins in 4.13 and don’t require as many steps to get working but you still need to declare them in 4.12

Thank you, mordentral. Just like you said, I haven’t packaged steam subsystem correctly according to the log. Didn’t know the -log option.
Now it works well. Thank you.

Is there any tutorial on the voice communication? I can’t seem to figure it out.

Ill check with the -log option too… but, I just posted a question here too:

https://answers.unrealengine.com/questions/507485/steam-online-multiplayer-in-v413.html

There isn’t much to them currently, you add in the ini variables in the OP and StartNetworkedVoice/StopNetworkedVoice if you are using push to talk. Voice has been buggy for a few engine builds now though and while 4.13 appears to have fixed a bunch of it someone reported that with more than a couple of users you still get network saturation (have to increase network saturation limit in engine settings).

You’d be better off not making answerhub posts regarding my plugin, there is no easy way for me to be notified of them and the last few Epic just said “Its a plugin we can’t help you with it” even though they weren’t plugin issues.

You can try with the typical host/find nodes and see if they work but generally your issue is when you don’t have the steam subsystem packaged correctly. You also do not have to manually drop binaries for it in development packages (don’t think for shipping either anymore but haven’t tried specifically in a while).

That’s good to know. I didn’t want to hijack your thread with a long discussion on my own problem. I did check the log file and it originally said it wasn’t initializing Steam correctly. I did a new dev build, dropped in just the steam_appid.txt file and fired it up. Connected right up no issues. Thanks for your help. I cant wait to get into the rest of what this plugin has to offer. Thanks for your work and guidance.

Welp, my vr plugin is getting pretty stable and I had a few spare minutes so I decided to add some love back to this plugin (see below).

Updated the plugin today, opened up the repository for it to the public and stopped the zip file method of distribution (subsystems haven’t really changed in a few engine versions).



**10/19/2015**- Opened up repository to the public, now that subsystems have been fairly stable

Added additional options to the FindSessionsAdvanced node (All Servers search, full only, empty only, secure only, minimum number of users).

Made CreateSessionAdvanced ignore "UsePresence" setting if bIsDedicated is ticked and force presence off (to help avoid misuse).


I have had several requests for supporting the authentication system for steam and wanted to be up front about it in here. The changes required are likely to be out of the scope of a plugin (or very backwards to implement through one) and I would rather people go and support the pull request that adds the functionality into the engine itself: https://github.com/EpicGames/UnrealEngine/pull/2135

Is it possible to use the voice features for spatialized output from the players character location?

Edit newp, the voice engine is still hidden behind a private variable in the voice interface. Can’t access with a plugin to modify the audio component volume.

Still requires an engine change to make work, or a hacky class override with a custom voice interface.

What you want is

The FRemoteTalker has a pointer to the UAudioComponent for the speaking player.

Bummer but thanks for the quick response.

For reference I linked to the wrong spot, in case you do decide to go in and open it up for yourself.

Would have to access that map.

Interesting… So is there still a place where a non-coder can download the working plugin for the versions they need? I don’t really know how to use a repository site like that. :confused:
Also, that Pull Request link seems to be returning a 404 page not found, for me… odd.

Have to be signed into github to see it.

Also all previous versions will remain as zip downloads, further versions (4.13.1) can be downloaded from the Downloads section of repository.

Edit: Oddly, I am signed in… hmm.

Thanks, I found the download! I just didn’t see that bit. sorry :wink:

Hi! I need some help. How can i get this cool plugin for v4.13.1? Or you dont have complete build for 4.13.1?
I have some errors when i cooking content for windows :
LogModuleManager:Warning: Found module file D:/FBGameProject/Plugins/mordentral-advancedsessionsplugin-83c2575600be/Binaries/Win64/UE4Editor-AdvancedSessions.dll (API version 3106830), but it was incompatible with the current engine API version (0). This is likely a stale module that must be recompiled.
Plugin ‘AdvancedSessions’ failed to load because module ‘AdvancedSessions’ does not appear to be compatible with the current version of the engine. The plugin may need to be recompiled.
:frowning:

I just uploaded a direct zip for it to main page.

New version uploaded to 4.13.1 and committed to the repository


**10/24/2016**- Added Advanced Identity Library to the plugin

This part of the plugin probably won't be of much use to most people, it was a special request.