Download

Advanced Sessions Plugin

Thx a lot mordentral i totally forgot to set the game instance in the project settings. Now it works!

does it work for android devices?

So you not going to add SteamCloud, SteamAuthentication to the plugin.
Did you hear something about a Engine Release date for those things?

Otherwise I have to create a Plugin on my own for those things.

Cheers

SteamAuth is a current pull request on GitHub, I think it is slated for 4.14, I don’t feel like re-writing a bunch of what will already be implemented soon anyway. I will probably provide blueprint access to it when it comes however.

Steam cloud has an interface for it already in engine, the only reason I didn’t add support for it is because of how much blueprint work I would have to add for specifically handling Files which is a plugin in itself.

yes it worked on my android devices :)))) thanks

Just as an update, when there are more than 2 players (3-4) the voice issues emerge again (choppy voice). Logs:


[2016.10.04-03.28.06:947][147]LogNet:Warning: Network saturated
[2016.10.04-03.28.06:947][147]LogNet:Warning: Dropped 1 packets due to congestion in the voicechannel
[2016.10.04-03.28.06:993][149]LogNet:Warning: Network saturated
[2016.10.04-03.28.06:993][149]LogNet:Warning: Dropped 1 packets due to congestion in the voicechannel

We have updated our project from 4.11 to 4.13 (update too), now it shows us:

16.10.06-19.18.23:649][186]LogLinker:Warning: Can’t find file ‘/Script/OnlineSubsystemSteam’
[2016.10.06-19.18.23:650][186]LogUObjectGlobals:Warning: Failed to load ‘/Script/OnlineSubsystemSteam’: Can’t find file ‘/Script/OnlineSubsystemSteam’
[2016.10.06-19.18.23:650][186]LogLinker:Warning: Can’t find file ‘/Script/OnlineSubsystemSteam’

any idea how to fix this?

Clean the project and rebuild, make sure you have the 4.13 version of the plugin.

Also SteamSubsystem is a plugin in 4.13, you’ll have to make sure it is ticked on in your projects plugins in editor.

Made a mistake in the initial post, should have been “(plugin too)”. I downloaded the 4.13 plugin and replaced it.

It’s a pure BP project so i can’t clean / rebuild it from VS, but i’ve deleted the saved / Intermediate folders and made a full rebuild on packaging.
Still not working. And the Steam Overlay is only working if i start the build out of steam. At 4.11 i could start the exe anywhere and it was working. Is this normal?

My DefaultEngine.ini


[/Script/Engine.GameEngine]
!NetDriverDefinitions=ClearArray
+NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="/Script/OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="/Script/OnlineSubsystemUtils.IpNetDriver")

[OnlineSubsystem]
DefaultPlatformService=Steam
PollingIntervalInMs=20

[OnlineSubsystemSteam]
bEnabled=true
SteamDevAppId=480
GameServerQueryPort=27015
bRelaunchInSteam=false
GameVersion=1.0.0.0
bVACEnabled=1
bAllowP2PPacketRelay=true
P2PConnectionTimeout=90

[/Script/Engine.RendererSettings]
r.Streaming.PoolSize=1500

[/Script/OnlineSubsystemSteam.SteamNetDriver]
NetConnectionClassName=/Script/OnlineSubsystemSteam.SteamNetConnection

You need to go to Plugins window and enable “OnlineSubsystemSteam” and “OnlineSubsystem”, I am not sure about this one but I think you also need to enable “OnlineFramework”.

Edit:


Thank you so much, it’s working!
Feeling a little bit dumb, but happens. :smiley:

Thanks guys!

Thanks for giving him pictures, was at work when he asked

Okay, now i’ve got another problem, and again, no idea whats going on.
Had to work on 4.11, and thought i can port it to 4.13 like yesterday.

Replaced the Plugins, activated the plugins in the settings, and i can’t package it. 4.11 is working though.


UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: VictoryBPLibrary.generated.cpp
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(16): error C2007: #define syntax
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(21): error C2007: #define syntax
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(26): error C2007: #define syntax
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(31): error C2007: #define syntax
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(36): error C2007: #define syntax
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(41): error C2007: #define syntax

(…)

Seems weird because there are errors of the victory plugin, too.

e/ okay working now. What i did:

  • Started the 4.11 project with 4.13 to upgrade
  • Failed because Plugins
  • Replaced Plugins with new versions
  • opened project
  • started build
  • enable plugins (as above)
  • started build again
    -> working

before:

  • deleted saved + intermediate folder
  • replaced plugins with newest ones
  • startet upgrade
  • build
    -> failed.

No idea whats going on. But at least it’s working.

Has anyone managed to get Dedicated server working with this plugin?

I have successfully got player user name using this plugin, but after packaging, tha call seems to fail. I have followed the instructions in this page

How can I make sure the plugin has been packaged successfully? Any hints will be helpful.

I am using Steam subsystem btw.

The plugin was made prior to the engine directory addition and i’ve never added “Installed” to it but left it as a manually added plugin for projects. Without changing the installed line and making sure the binaries are built to your version (if an un-updated version) you have to add a blank c++ class and include the plugin in the buildtarget.cs “AdditionalDependancies”.

I generally build all binaries but I don’t know that providing it at an engine plugin is the best idea considering it isn’t a marketplace item and still requires manual installation anyway and being able to recompile it as needed is useful for users.

How can I find all the sessions with steam appid 480?
Because it finds only games that my steam friends created

Thank you for your answer and this great plugin, mordentral.

I have added the “Installed: true” line to the .uplugin file. So I don’t need the c++ file, right?

And how can I make sure the binaries have been built to my version?

Thank you in advance.

If the engine version matches the version that you downloaded you should be good. Otherwise you either need to rebuild engine with it in the engine plugins or move to your project and rebuild the project, at that point it would be easier to leave it at the project level and include it in the build target.

480 is region locked, if you are trying to get sessions outside of whatever the region bounds are then you are out of luck. Also the engine itself auto filters sessions using different builds from returning (you can see it in the log).

Valve doesn’t want 480 to be used as a proxy connection for released games or projects, just a temporary setup id to get programs working with steam, so it is a little limited.