Download

Advanced Sessions Plugin

Strange… i guess I havn’t reverted it back properly. I’ll dive in deeper to that tonight.
Thanks for the help and love the plug-in. Great work :cool:

What subsystem are you using?

I am currently trying to call the function ‘Get session settings’ but it is failing everytime.
I want to update them so that other players know in what map the current session is playing.
There are also some other functions that are not working in my project like the ‘Is player in session’ function.

It seems like that the reference to the session data got deleted or something?
Is this a know bug of could it be that I am doing something wrong.

Thanks in advance :slight_smile:

Null or none at this moment as I’m building a lobby and matchmaking system. It’s working I was just wondering why the error keeps popping up?

Its not giving the player a unique net id, that error is shown if the unique net id is empty. Are you testing in editor?

GetSessionSettings only fails in two isntances:

There is no session Interface (no subsystem using sessions is active).

The session interface doesn’t support sessions (probably attempting to play through editor).

The log will output an error message to you when it fails saying which one it is.

Yes I am currently testing in the editor.

So if I am understanding you correctly then I should try this out in a build and then it should probably work?
I will try that tomorrow thnx for the reaction!

For what its worth i could never get 137 working with unreal, 136 seems to work perfectly fine so long as you remove the steam controller plugin from the engine

Greetings! It would be awesome if this could have access to the steam authentication, there is no way I know of to access that in blueprints and its pretty important to have.

I am trying to avoid adding steam specific code to the plugin, there are only a few exceptions so far and I have to have them not compiled on non steam platforms. It would be better for the base subsystems to support authentication access, there is already a pull request for the engine up on github to support it (steam authentication) and they are redoing parts of the subsystems anyway at the moment.

I tried listening to OnSessionInviteReceived from a game instance (extended advanced friends game instance) and i dont seem to be getting the event.
Is it working for anyone else?

OnSessionInviteAccepted does fire off. And I see the OnSessionInviteReceived get registered but still no event…

Alright I see, do you have a link to the pull? Hopefully steam authentication is supported for blueprints soon.
Thanks!

Has anyone done a tutorial or explained the voice chatting?
I haven’t been able to figure that out.

I assume I’m just being stupid, but I am extracting the zip to engine>plugins>advancedsessions. The plugin shows up in the editor and prompts a restart to apply, but brings up a dialouge box saying there are missing / incompatible modules. Anyone know what I’m doing wrong.


226160f913edb80724755a3c57af63de55852702.png

You need to extract it in your project’s folder, creats a new folder inside your project, call it “Plugins” and just extract it in there.

Do you plan to find session over the Web, without steam, with ip adress or name server? (like “open ipadress”)

Hi.
Thanks for this great plugin. Currently trying to package project and receiving a fatal error LNK1181: cannot open input file ‘tbbmalloc.lib’. Maybe you know what it could be?
Project is on 3rd person blueprint template. Engine version 4.13

Hey guys i have problems casting to my game instance which is a child of the Advanced Friends Game Instance. I always get a failed cast out of it. I am using GetGameInstance and cast this to my game instance (child of advanced friends game instance).
I’m using the 4.13 version of UE4.

Any fix for that?

No, but there is a subsystem for that somewhere in the forums here that would work with this plugin.

There shouldn’t be an issue with that, are you sure you assigned the correct game instance in your project settings?

Don’t think it has anything to do with my plugin directly, UE4 answerhub has a bunch of questions about that and most deal with visual studio being incorrectly installed.

Just a follow up: voice issues are resolved in 4.13! Cheers.

This post?