Download

Adding point lights and cpu usage

Hi,

I added some static point lights to my scene and now when I build lighting, task manager only builds using average of 35% of cpu core power. Any reason as to why I ma not seeing 100% usage?

I let it build all night it still says 0% on the build and now cpu usage is at 6%. Obviously something is wrong. This only happens when I add point lights. I delete them and it builds fine. Swarm agent is still collecting photons. Or do the cores drop off after they finish calculating during the collecting photon stage? It started with 40 lines now it is down to 3 lines. Strange that adding a few point lights would take so long?. It must be something wrong in my set up.

Swarm agent appears to not be progressing. It is just kind of blinking and the progress slide has not moved forward.

Which version is this happening on? And could you try adding point lights to a blank map, place a lightmass importance volume and build again?

This is 4.8.3…Ok I will try it.

I placed some in a blank level and it was fine. My guess is it’s my set up. I probably have something wrong. I just do not know what it could be. I opened up the UE4 Level tutorial that I did a while back and it built just fine too.

Here is the set up…

Point lights.jpg

Ok, post some screenshots of your level and lightmass settings in World Settings please.

Here is an image of what is going on outside. And an image of my light mass world settings. Please let me now if you need to see anything else.

Thanks,

Aaron

Light Mass World.jpg View from outside.jpg

What happens when you scale the lightmass importance volume down enough to cover the building?

Ok. I made the light mass smaller it took about an hour to finish. I think it solved a lot of the problems I was having.

Here is the light mas volume. It is a bit bigger than the house. It covers the extents of the imported static site mesh that the house sits on. Can you have more than one light mass volume? I read something about priorities. How does that work?

6c5a11a3ad23ca4014bcebcf12c80f76617c6110.jpeg

Here is the interior view. The lighting looks much better.

f7272abbe8d15109770de5434851a489a09942f7.jpeg

The only thing that looks off is the shiny metal surfaces. I am using the brushed nickel from the starter content.

e9b71ffc37c4b023de55da347318cc4b199d49c7.jpeg

Yep, the area you wanted to build the lights for was way too big.

You need to use reflection capture actors to fix that metal reflection issue.

Thanks for the help.

I my research I read something about having multiple light mass volumes and setting priorities. How does that work?

Also, my glass reflections have some blockyness to them. Any idea what might cause this?

38ffeec768e0a8d25c45a2607fd251a3613242ae.jpeg

You would only need multiple lightmass volumes if you had, lets say, one more house you want to build the lights for very far away from this one. In your current case however one is all you need.

As to glass reflections, thats as high as the resolution of reflections go. What you can do to get better looks it is to use a cubemap inside the material to fake reflections.

cube map, like a equilateral HDRI?

Yes. You can see an example of it in TranslucentWater material of the Water Planes content pack.

Cool. I have lots of good HDRI’s.

Thanks

I forgot to say, you can also generate a cubemap of the environment using a Scene Capture Cube actor and Cube Render Target texture. An example of it’s usage can be found in Content Examples project’s Reflections map.