Adding classes BUG

Not sure if Im doing it wrong or if it is just a bug but it’s driving me crazy.

I have problems adding a new class in my project, Im trying to add an “AIController” class with an unique name so it can be created easily by engine, but when I hit create it says that it Failed hot reload and that name is already being used which I don’t see other .h or .cpp file using that name. I tried with different classes and its same, I actually don’t have problem creating Character classes.

Im using 4.7.2
Running Windows 8.1
Compiling with “Development Editor” with 64Bits.

No one?! Srsly?

Try to close Unreal Editor. Then rebuild your solution in Visual Studio (under Build menu). Then run editor again from Visual Studio (Debug->Start Without Debugging). And then create a class.

Hi Georgespartan01,

Thanks for your report! I was able to reproduce this behavior in 4.7.2, both in Blueprint projects and C++ projects. I’ve entered a bug report for issue (UE-11908), and I’ll let you know as soon as I see an update on it. Keep in mind that after this fails, reopening project will also fail to compile. You’ll need to manually remove classes you tried to add from your project directory, and then recompile project.

Thankls for repply, actually to make it working I had to add “AIModule” on .cs Build file, that fixed all. Thanks again

Thanks for workaround! I’ll add a note to bug report about it.

Hi again,

I just got notice that this has been fixed internally and should appear in 4.8 when it is released. Thanks again for report!

Im glad to help!