Adding a new layer paint, will turn the 'base' layer to be black


I am doing some tests with the landscape, and I managed to create a material with 3 layers, cliff, dirt and grass. It contains 9 textures (Bump, normal, and diffuse). When I use Grass and dirt, it works out fine. But when I add the cliff layer (within the same landscape component), it turns black where its full cliff. I paint a differnt componentwith grass and cliff, and it looks fine, but as soon as I add a little bit of dirt, it turns to black the cliff component.

Please let me know how I can fix this.


Grass and Cliff

Add a tiny bit of dirt.

Hi ,

This is unexpected. We’re going to try to reproduce the issue here and I’ll get back to you. Can you let me know what version you’re using? Also if you are able to attach the material asset you’re using, that would be helpful.


Here are the textures I used.

And here is the uasset. For now, I changed all to heightmaps, and try to avoid the black blending problem by painting carefully. In the question, I changed the cliff (both diffuse and normal) to alpha.

Did you manage to reproduce the error?

Hi ,

If you change the cliff from an Alpha blend to a Height blend do you still see the same black splotches appear?

Hi !

For the time being I changed them all to HeightBlend. This way all 3 render properly. Except on the known issue where the 3 textures meet it will show up as black. This is a known issue described in the documentation for Landscape materials, their solution is to change one to alpha blend mode. The problem is that then the cliff (The alpha blend one) will not render as described on the question.

Does the cliff texture have an alpha channel? You can check this by double clicking the texture itself. Open the view dropdown menu and make sure only “alpha” is checked. Additionally what type of file is the cliff texture you are using? Is it a png?

Unfortunately I am away from my pc for a couple hours. AFAIK the texture is a TGA, 32 bit compression. It does have an alpha channel that I use as a height map. You can check the tga file from here. https://www…com/s/uhaaycotivv7cwi/T_Cliff01.tga?dl=0

It does have an alpha layer.

Hi ,

Unfortuantely I’m not seeing a similar error on my end. Try replacing your blend node with weightblended layers, does the same black splotch occur or is it limited to the landscape layer blend?

Is it possible this is a limit on my end? From the amount of shaders a landscape element can have? I’ve seen on some forum post that some people can have no more than 3 or 4. Maybe my PC can only support 2? Although, I have no problem seeing the material for the Landscape Example, which has more than 3 layers though.

Did you look at the material asset I made? Maybe I did something wrong?

I’ll give the Layer Weight Node a try too.

Sure! Here it is!

Hi ,

I doubt it, but if you could, please post your dxdiag and I’ll be happy to have a look and see if this is a limitation for you. You can find your dxdiag by going to the start menu on your desktop and typing “cmd” into the searchbar, then open the command prompt program. Type “dxdiag” into command prompt and press enter, then save the dxdiag in a text document and post it here.

Nope, it definitely isn’t your pc hardware, that is all well above min recommended. What happens if you paint over the black area? For instance, if you paint the entire landscape section when a part of it turns black, does the spot go away eventually or does it keep shifting around even after the whole segment is painted?

This is what it looks like.

I exported the material, in case you wanna try it yourself. I removed the alpha from the cliff texture.

Hi ,

Does this occur with any other texture in the material or is it only with this particular cliff texture?

I tried using the rock_basalt from the default content, I the problem was still there.

I am going to steal the material from the content example, and add in my textures there, see if that will generate the issue, or if it will work again.


This should have been solved quicker, but I managed to nail down the issue.

So, for all layers you should use the LB Height Blend type, EXCEPT for the ‘base’ texture, which will be the one that would by by default, ie, the one that would be at the bottom of the layer. (Correct me if I am wrong, but I found this the easiest way to think about it)

This base layer should be set to LB Weight Blend type! I was using the LB Alpha Blend, which was what was causing the issues I had.