Actors not on ground in packaged project

I have a project with creatures. They move randomly around. In the editor, all is ok. It doesn’t matter which editor mode I use: simulate, viewport, standalone game - all are ok.
In the packaged project, the actors float above the ground (see screenshot).
What could be the cause of this? Where do I start looking for the bug?

Hi btengelh,

Which version of the editor are you currently using?

Also, would you be willing to post the character asset for us to test?

Hi TJ,
I’m using 4.51
I have prepared a project with the asset in question. Can you give me your email so I can send you the link, please?
Happy Halloween

If you could, please send it through a private message on the forums.

Hi TJ,

I sent you the link to the project a couple of days ago via PM in the forums.

Just want to be sure you got the link and could download the file?

  • Ben

I got it yesterday afternoon, it actually took quite some time to download. I will be looking at it as soon as I can and post back here.

Did this also happen with an version earlier than 4.5.1 or did it use to package correctly?

It didn’t happen with 4.4.3 as far as I can remember. Started with 4.5.

I’ve been attempting to find a solution but so far I’m unsure of the cause. I have created report UE-4964 in our tracking software and have asked our developers to investigate further.

As soon as we have a suggestion, we will post back here.

Thank you! I hope they can find the cause :slight_smile:

Could you add a screenshot of the component tree from the BP editor? My guess is that you are using an ‘editor only’ component (e.g. a billboard) in the hierarchy somewhere, which is being stripped in the packaged build. Obviously we need to stop you from doing that, but would be good to know the exact cause!

Here’s the screenshot. TJ Ballard has the whole project. I can’t see anything special…

I found out that setting the mesh component location z to -97.01 seems to change a lot. I created the monster blueprint with the mycharacter blueprint from the sample content (“create blueprint based on this”). This seems like some check during the package process compares location and rotation values and if they are equal something is messed up. the monster character does not turn to the moving direction in the packaged project, too. Again, in the editor, EVERYTHING works just fine.

Hi TJ,
are there any updates to this problem?
Thanks, Ben

HI btengelh,

I tested this in the project you provided me and it is odd behave indeed. I have gotten with our dev team again and hope to have a response for you soon.

This still does not explain the error, but it might be helpful in tracking it down:

Hi TJ,

thanks for the info. I’ve posted a new screeshot below. It seems to be a problem with the parent class somehow… I hope that helps finding the bug.

Where exactly are you changing this setting? I’m in the BP_goblin001 blueprint Event Graph and I’m not seeing that option.

You have to click “Blueprint Props” in the toolbar. Should have mentioned it, sorry :slight_smile:

The issue persists in 4.6

Any news?