ActorChannelFailure while debug use Nsight Tegra


I’ m trying to use NVidia Nsight Tegra (ver. 3.3.16047.9615) to debug my multi-player game. But I got a ActorChannelFailure message from server’s log. I already search for solution about the question. (ex: Dedicated Linux Server). But it seems no use for my situation. Because I already rebuild the server and client in many times. The failure is still exist. On the other side, the client of win64 version works well. That’s weird. Is anyone could give me some suggestion or information?

My Engine version: 4.11.2
and Nsight Tegra version: 3.3.16047.9615

[Update]: If I build an apk with Unreal Editor and install it on my android phone. It works well.

Hey wingedrobin-

Can you provide the full error message from the logs? Do you get the same error if you debug without Nsight Tegra? If you’re able to reproduce the error in a clean project, can you provide the setup that causes the error to occur?


Sorry about being late. Unfortunately I encounter another difficulty is that I build an apk with Unreal Editor and install on my phone. It can pass the login process and works well. but after that, I retry to debug on NSight Tegra, it pass the login process and ActorChannelFailure did not occur again. I guess this situation might be cause by using some configuration of apk that I built. So I clean up some data in folder binary, intermediate, save/cooked, save/stagebuild, and run Nsight Tegra again. Then I got a segmentation fault when game is launching. Now I even can’t finish lunching my game. Did I do anything wrong?

I’m not sure I fully follow your steps. After re-packaging and installing the project, are there any errors? When you attempt to debug, can you provide the exact error you’re getting? Can you let me know if you have the same problem debugging an empty project?

Q1: No.
Q2: Now I encounter the Segmentation fault problem, I can’t launch my game and test the login process, so I cant’ provide the whole error message about ActorChannelFailure right now, sorry. :’(
Q3: If you mean the Segmentation fault. Yes, as follows.

If you need this empty test project, just tell me which files or folders you need. Thanks. :slight_smile:

Hello wingedrobin,

I’ve tried reproducing with a fresh C++ project as you mentioned but I haven’t had the same results. When you mention “Then I run the Nsight Tegra Debugger”, are you just launching the project in Debug for your Android Device, as in right-clicking the project name and selecting Debug > Start New Instance or hitting the “Nsight Tegra Debugger” button on the toolbar, or are you doing something else?


Thanks for reply. I just hitting the button on the toolbar.

Let me explain my issue again and hope there will be some useful information.

  1. Use Nsight Tegra to debug my project and encounter the ActorChannelFailure issue. (The game is auto deployed by Nsight Tegra.)
  2. So I try to build an apk with Unreal Editor and directly install it on my phone. Works well without ActorChannelFailure issue.
  3. Back to step 1 and test again. (Auto deployed) But the ActorChannelFailure issue didn’t occur again. I guess there could be some issue in build process. So I clean up some data in folder binary, intermediate, save/cooked, save/stagebuild to let them rebuild again when in step 4.
  4. Retry to use Nsight Tegra and encounter the Segmentation fault error when loading.
  5. Create a whole new project and try Nsight Tegra, still has the Segmentation fault error.

If you need any other information or details, just tell me, thanks.

I just noticed from the output log in your picture that you seen to missing some symbol libraries. Could you post the entire output log from one of these debugging attempts?


Here is the output log of the Segmentation Fault Log. There might be a little bit different from picture above, but I think it is no big difference. Both are same problem in loading shared library and But I can find these two file in my \Intermediate\Android\APK\libs\armeabi-v7a folder. Is there any clue? Thanks.

I apologize for the delay, I spoke to someone about this and it seems like these missing library messages are normal and we can ignore those. We need to try to take a look at the LogCat to find out what is causing this Segmentation Fault. Could you get that from the device? You can see how to do that here if you’re not familiar. How can i get full log from android? - Mobile - Epic Developer Community Forums


Here is the output log of logcat. My phone is Samsung Galaxy S2 i9100, but I think that is not the problem is, because the segmentation fault issue is also occur on Xiaomi Mi 2S. Thanks. :slight_smile:

Thank you for the additional logs, Wingedrobin. After taking a look, it seems like this error message could be pointing us toward the problem:

06-15 10:15:37.675 10101 10160 D UE4 : Assertion failed: HasFoundDataDirectory [File:C:\UnrealEngine-4.11\Engine\Source\Runtime\Core\Private\Internationalization\ICUInternationalization.cpp] [Line: 117]

06-15 10:15:37.676 10101 10160 D UE4 : ICU data directory was not discovered:

After looking up previous reports of that I came across this post which mentions that it may be caused by invalid characters in a file path. Could you check any of your project’s directory’s folders for special characters that aren’t usually accepted by UE4’s standards? This would include any spaces in file/folder names as well.


Yes, There had a space in my folder name (C:\Users\User\Documents\Unreal Projects\WholeBlankProject). Then I modify it into C:\Users\User\Documents\UnrealProjects\WholeBlankProject and regenerate the .sln file, re-build it again. But unfortunately still got the segmentation fault. Did I miss anything after the folder path was modified? Here are the output log and logcat message. The ICU problem you mention above is still exist. Any other idea? Or need other information? Thanks anyway. :slight_smile:

Hello wingedrobin,

It seems like this issue is related to the ICU problem but it’s not exactly what I thought it was. It seems like the OBB may not be installed on your device, which can be done using the batch file with the packaged build. Also, ensure that the option for 'Disable Verify OBB on Startup" is checked.

If it still doesn’t work and the OBB isn’t the problem, try editing in Engine/Build/Android/Java/src/com/epicgames and force HasAllFiles = true on line 168. This’ll stop the OBB installer from running.


As I mention above, use the install batch which generated by packaged build and attach process to nsight is work well. But package a new build in each time is not so convenient, right. :slight_smile:

I check the *\Android\obb[Project Name* folder in my device after auto deploy by nsight, it really no any .obb files in there. So maybe it could be the problem, I guess. But the method you said seems no use for me. Still any other idea? Thanks anyway :slight_smile:

Unfortunately I’m not having much luck finding any alternatives. Have you tried installing the OBB once and then continuing from there without doing it every time?