Download

Action RPG Inventory System

Thanks! I figured it out with the weapon system I use :)!

4.20 does not work currently. Just tried to upgrade from a blank 4.19 Action RPG Inventory project to 4.20. Instead icons just white boxes are painted. Except at the two iventory slots that has some start items set. If you drag and drop the apple into one of the white boxes it still remains a white box (tooltip does work). You can drag and drop back from the white box into the first slot and it’s painted as apple again. That white comes from the “Button” in the Inventory_Slot widget. However I’m not sure why there is no image update on the empty slots anymore.

screenshot.jpg

Hi I offer support when i can, I will look into this issue later today and post up a fix if no one else has by that time.

Here is a fix

Here is a fix.

Updated to fix the issue with losing the Paper Doll Equipment Slot background icons

Replace ItemInformation.icon on the Icon image with a new function with the logic below, create a new Texture 2D variable a name it PaperDollIcon set it to the properties shown in the image and set the default value to the T_UI_Slot, then in the Equipment widget click on each InventorySlot and set the Paper Doll Icon with the image found in the boarder element above it or to your own custom image if you have one, after this is done the the boarder can be deleted, this will needs to be done for all the UMG Slots.

It works well. Thanks for the fix.

Version 2.0 - Submitted - July 20th 2018
------- Update Notes -------

Fixed inventory slots showing as white icon boxes (UMG issue Epic never fixed)
*Use OverRated’s fix posted above. It’s not a perfect fix as you lose the Paper Doll Equipment Slot background icons. But you can manually reassign those by *editing the **Equipment **UMG file and update each of the **Inventory_Slot’s **PaperDollIcon with the correct slot icon for each equipment slot.

Inventory_Slot]

  • Go into the*Content/InventorySystem/UI/Blueprints/Inventory/*Inventory_Slot UMG file and select the Icon element.
    Then replace the **Brush **binding to ItemInformation.Icon with a **new Binding. **
    The attached screenshot will show you where to find how to do that.

  • Create the logic as shown in Overrated’s Post for the new Brush binding.

Then do the same thing for both the *Content/InventorySystem/UI/Blueprints/Inventory/*HotBar_Slot and Container_Slot UMG file.

Hi Neutronux,

I have updated the fix to correct the issue Pirate mentioned above with the Equipment Slot background, I didn’t take into account how the backgrounds where being displayed so i have updated that also.

I’m trying to convert the project to a top down view. I’ve puzzled most of it out, but the equipment character parent is messing with the movement of the inventory character child (i’m assuming it has something to do with the equipment slots). any suggestions on how to change equipment character blueprint to not mess with movement of it’s child?

Movement changes should be done in the parent if your game is solely a top down view so the changes apply to other characters classes to, the child’s values you set will overrided the parent classes.

I have an issue within my ARPGIS merged w/ MTD kit and this issue is in a default MultiplayerTopDown kit (4.19 & 4.20) on a marketplace aswell, as you can see on image 1 window - host, 2 window - client and on a client side player names are not shown. Any 1 who ve fixed it alrdy? Will apreciate any suggestion.

If I add an extra skeletal / static mesh variable into the inventory item structure. When I try to retrieve the information I get nothing?
Any other variable type seems to work.

[Yes I changed the value inside of the item data table]

When I use print string it does not even come up as ‘none’ simply an empty space.

Am I missing something more that I need to do?

Thank you.

**

Any notice about updates?

Are you after the 4.20 update or something else? this system is pretty much offers everything that a inventory should.

Hi all, I recently purchased the Action RPG Inventory System for my project. I am using 4.20. The above mentioned fix cleared up my equipment items being whited out, but, I am unable to pull up my backpack at all. The storage item “open pot” items are also whited out for me. I would appreciate any help in this matter, Thanks.

The same fix is also needs to be done on all slots including the container slot widget which will fix the white slots on these actors, if your inventory isn’t coming up then you may have changes something which wasn’t meant to be or you haven’t set it up correctly in your own project.

I will do the same changes for the slot widget but it is in a newly created project with just the inventory system. Thanks

If your still having issue with the inventory opening let me know.

Hmmm, interesting, after creating a new project with only the ARPG System in 4.19 I still have the problem with the backpack inventory not toggling open or closed. So, it is not a problem with the patch it would seem.

It seems to work fine for me on both 4.19 and 20 are you using the correct key?

With a new install and no modifications to blueprints, when i press “c” i get the equipment toggle only, “b” does nothing, and “i” toggles equipment only.