Download

Achieving realistic reflections

Hi,

I’m working on a small arch-viz scene and I’m stuck with getting the reflections right. They don’t look realistic and I’m wondering if I should use SSR which in some cases helps in some makes it worse. I have attached two images, one without SSR where the roughness of the material is right, but the reflections from capture spheres on the floor look very strange. On the second one, with SSR switched on reflections look correct, but I’m loosing the roughness of the material. What should be the right approach to achieve realistic result?

Thanks for your help.

5a9a5fe9a54980f2f5fb943d1705c04bec3fa0d9.jpeg

84643b689680dbcac1c35001c4baf38b5c0a9a5f.jpeg

And here is the photo I’m trying to match (design and photo by Bruzkus Batek Architekten):

21a4497082969e991907bccf7f6eacb177124aed.jpeg

You should be using the box reflection capture actor for a rectangular room like this.

Looking good!

Here I copied this from another thread, give it a try:

  1. Add a “Scene Capture Cube” in your scene (it will look like a camera in the viewport).

  2. Create a new “Cube Render Target” in your content browser (it’s under "Materials & Textures).

  3. Add the Cube Render Target you’ve just created in the “Texture Target” on Scene Capture Cube details:

  4. Now you can add the “Cube Render Target” as a node in your material.
    Combine it with a color and plug it in the Base Color channel of the material to fake the reflection.
    Don’t forget the “Reflection Vector” node to adjust the coordinates properly. Example:

Note that the location of your Scene Capture Cube is very important as it will determine the center of your cubemap.
You can think of it as a replacement for the default Reflection Capture, but with the possibility of increasing the resolution
(under Cube Render Target details) and with real time capture (it will be much more expensive because of that).
You can disable the real time capture under the Scene Capture Cube details panel (disabling “Capture Every Frame”).

with reflectionmaps you never get precise borders to the floor…that makes them useless for floors and such where reflections add a big amount of a materials property. SSR is the better way to go…but as i understand they can be used only with a low roughness…it would indeed be nice to force SSR with higher roughness values…but i guess the blurring cant be done in a good looking way in realtime?

The default quality setting for SSR doesn’t do blurry reflections for performance reasons, but you can enable them:

In your post process volume simply set the SSR quality to 100 (and optionally raise the max roughness value) and you’ll get much nicer blurry reflections. It does come with a slight performance cost, but in a scene like yours this seems to be worth it.

Thanks guys for help! It was all very useful and combination of all the tips worked out finally.

Here’s what I did:

  1. Changed Capture actors from Sphere to Cube - much better!
  2. Set SSR to highest level and tweaked shader file to get even better results
  3. Added normal maps to floor material to help diffuse SSR reflections some more
  4. Increased Temporal AA settings to get rid of the noise in the end it looks fine

Link to finished project on the forum:
https://forums.unrealengine.com/showthread.php?97723-Photographer-s-Loft-in-Berlin-(Bruzkus-Batek-Architekten)