About Mesh Decal issues in 4.13

110267-decal.jpg

When the camera closed to the model,it seems OK.~
But When the camera was far away from the model,the Mesh Decal would display in the front of the canopy.

Thank you.

This looks like a translucency sorting issue, which is caused by translucent materials in the scene. You can adjust the translucency sorting order for the mesh decal to correct this, but be aware it may cause issues elsewhere with other translucent materials in this area for sorting issues.

My suggestion above is based on the assumption that the purple window drapery is using a translucent material as well. If it’s not, Can you post your detailed steps to recreate the issue and I can start from that. I haven’t been able to reproduce the issue you have otherwise.

Thanks!

Hi,Tim,I really appreciate your answers with patience.The picture
below is some details with my question,and look forward to your reply.
Thanks!!

In your project settings, try changing Early Z pass settings.

I have the same problem :

I’ve asked the same question on the forum : Mesh decals distance problem - Rendering - Unreal Engine Forums
Apparently, the shader is pushing the geometry towards the camera based on depth to avoid Z-fighting.

Thanks to Vebski on the forum, I tried a temporary solution : In MeshDecals.usf line 106 you can tweak the 0.0001f in “Output.Position.z += 0.0001f * Output.Position.w;” or comment the line if you don’t want any offset. It did the trick for me.

Currently, the issue here is a limitation of mesh decals and you’ll have to make adjustments. I just posted some things to be aware of and known limitations on this post here: https://answers.unrealengine.com/questions/485322/mesh-decal-limitations-or-bug.html

I didn’t mention it in the other post, but the one you point here would be one as well since we need to tweak or expose depth bias (cvar or per mesh/material setting).

Thanks a lot, pixoloco . It did the trick for me too!

It worked great! Thank you friend!