Able Ability System Info and Support Thread

The project was uploaded. The Able abilities are under Content/Spells. There are only two of them. You can cut them out to launch the project and avoid the crash, then paste them back in to open them.

Am I supposed to be able to play an animation montage through the able system? When ever I add one the timeline goes blank and the animation just doesnt play at all.

The update fixed the background issues on 4.21 and 4.22. However, I have problems with the preview and target actors. The filter does not work, so all assets are available to choose still no matter what I put for the filter. I also cannot spawn in the target actor. Clicking on it or the reset target actor button will not do anything on 4.21 and 4.22 for me.

There is also a problem with playing the ability for me on 4.22. I created a new project in 4.22 and tried to make a ability, but I cannot preview it because the play ability in the able editor does not work properly. I have to press stop, backward step, and then play for it to properly preview the ability. Just pressing play or stop and then play does not work.

How would you suggest I debug why I can’t get an ability animation node to play on my player character? The animation will play if i use the single node, but with the ability animation node setup similar to the tutorial the HasAbilityAnimation Function always returns false. Is there a verbose option somewhere or should I build this and step through the code?

I cant seem to find a blueprint node anywhere, but there seems to be a “get base play rate” node, but not a set playrate node in the ability. Could I suggest this as a binding or a simple variable?

Interesting… I’ll look into that. I’m going to do some heavy testing on the preview / target actor flow this weekend. Not sure what could be causing your play/stop issue, but I’ll check that as well.

There is a Verbose option on the Play Animation task. You can try that and check your log to see why it’s failing.

Play Rate should be bindable.


Hey…I can use your plugin to make the received damage actor to do a hit reaction from hit location?

I purchase your plugin and I’m trying to work with this but, when I try to create any ability…the editor always still blank without any mesh character ou animation…Your tutorial are obsolete and don’t show how to fix this problem…only say:

“If this is your first time opening the editor, it will ask you to select an asset to use as the preview asset. In this example, we’re using SK_Mannequin which is the default UE4 Mannequin. If your Mannequin isn’t facing down the right direction (e.g. the same as the red arrow), you can modify it in the Editor Settings tab as in the screenshot.”

I alright select SK_Mannequin, alright select the blueprint actor character and nothing…

Any help???

Same problem here too…Trying in 4,21 and 4,22

Someone with discordID can add me and help this plugin works???

Hey all,

Easter ate into my time this weekend but I’ll be looking at things today/tonight and try and get a quick bug fix out for some of the issues people seem to be running into (especially the preview actor stuff). Thanks for your patience.

EDIT: And I immediately found some of the issues. At least with the dynamic binding not working properly. Going to fix that, Preview Asset/Target Asset (hopefully) and get a crash fix out assuming 4.22 plays nicely.

I found one way to pass the issues that I’m having with preview actor…maybe an bug or unhandled exception…below the steps that I use on a fresh project:

1º Create project, activate the Able Ability System in plugins list and restart the project;
2º Go in character BP and add Ability Component;
3 Create some ability BP;
4º Cancel the first windows that show all ue4 + plugin classes;
5º Now only show the classes from the project…here I select my character BP;
6º On editor…when not showing nothing…I click on preview mesh that I select before (at toolbar) and him will be shown.

Improvements: This steps above are not explain in tutorials.

Maybe another problems, bugs or unhandle exceptions:

1º When I try rotate my character mesh on Ability Editor, the preview of Ability with all tasks don’t work;
2º I try to rotate my mesh and camera in character BP and back to Ability Editor…when I hit play the UE4 crash;
3º If I click on validate button in toolbar, the UE4 Crash;

If you need I can post some screenshots or upload the project…
PS> I’m using the UE4.21.2.

Right that you will fix\improve all,

Uploading the project is the best way. You can upload it here: Dropbox - Submit files

Appreciate how quickly you review and resolve issues. Great work and also a great product!


I did upload of an blank third person project with the problems above replicated in UE 4.22.0 version.

Thanks Teak. Means a lot.

Perfect! Thank you.

Alright, Able v3.0.3 is submitted. It fixes quite a few bugs with the 3.0 update, including dynamic fields not working properly, the Preview/Target drop downs not properly populating, and a crash with channeled abilities (which is what was biting @Demonrras )

I have a lot of issues with new version using custom task created with blueprints.

  1. Crash when building DependencyList on PostLoad() - basically I can not create custom task using blueprints because of this crash.
  2. When creating new custom task there is a crash when creating custom scratchpad.

Basically I think you should try to make some easy custom blueprints tasks to test things out.

You can create the same task as mine: lerping owner position to target position using tick.

Last time when using 2.0v everything worked smooth. Now I’ve updated to check things out before Epic Jam and basically can’t use it :smiley:

edit: when doing the same task using c++ it is working without crashes.

The crash you’re describing is due to a Custom Task not getting properly re-instanced (so it leaves a nullptr which crashes DependencyList).

3.0 should have fixed that. In my local testing it would always properly replace the old task (you need to save any changed abilities, but it does replace it). If you have a sample project that shows the issue, you can upload it here: Dropbox - Submit files