A way to reset an overlap event and play in reverse

Hi , I have a moving platform when character overlaps box. It starts at the top , goes down(with character on it), and stays there. It is on a timeline. but when I get off , and then back on, it don’t do anything. I am looking for a way to reset it so when I get off , then go back on it and overlap box again , it plays in reverse and the platform goes back up. Thanx

Like this:

( It’s the FlipFlop that matters, not what kind of location node you’re using… )

Thanks for reply. so this is what I have. but when I put the flip flop node in , the platform doesn’t move at all. mine starts at the top , then goes down.

Ok so it started to work. something odd with the initial overlap. when I overlap at first it don’t do anything. then I step back a little out of the overlap and it goes down. works good from the bottom , when I get off , then get back on, it goes right up.

its almost like when I end overlap , it then triggers the platform movement. but only at the top. when its at the bottom it works normal. I tried putting “event actor begin overlap” at the beginning. it seems to work a little better . down once, back up once. then if I step back on it , it don’t move . step off and on again and it kind of takes off without me.

the flip flop node is doing something weird to the box overlap. when I take the flip flop node out , the box overlap works perfect every time. but the lift just wont come back up , when I overlap at the bottom.

on the timeline, how do you get that 0-1 on the new track pin? though I have the X float there now. my pin still says “new track”, I see now that the flip flop is trying to do both play and reverse at the same time. if I put a delay between the B pin and reverse , it will go down correctly. but then automatically goes back up after the delay time .

Hi, sorry wasn’t around.

So the float in the timeline just goes from 0 to 1, and that’s why I called it 0-1. It’s much easier to have 0-1 in the timeline and then multiply it outside, otherwise you have to keep going in and fiddling around with the timeline.

The flipflop wont be doing anything weird with the overlap. Does you box occupy the whole of the lift surface?

Also, are you setting that start and end point in world location ( ie, are you setting them outside the BP )? That wont work if you’re using a SetRelativeLocation node inside the BP.

( You can do the movement using world location, but then you need to use a SetWorldLocation node… )

Sorry for spamming the comments. I was posting as I was going along.No I didn’t do anything outside the bp. now I got it hooked up just like you did. Except I am using on component begin overlap , referencing the box. Since when using the event begin actor overlap , the lift would always kind of take off without me just as I would approach the edge of it. Something weird happening with the overlap. I would get on and step in the box , and the lift would move like 2 feet down then immediately right back up. Sometimes not move at all, or start moving when I step out of the box or only when I was right at the very edge of the box overlap.
The box does not cover the entire lift , It is centered in it so I am more on it when I overlap… When I removed the flip flop, then the box collision worked perfect every time. so I ended up sticking a do once node between the A stream and B streams and timeline. Then coming out of “finished” on the timeline and back to the resets on the do onces,It works perfect nearly everytime now , but sometimes after 3 or 4 times , it will not move at first when I get on(I have to step back off , then back on) for it to move. Sometimes when going back up it will hit top and immediately head back down before I get off. Weird that it would work perfect several times , then all of a sudden not work.
I’m gonna make the box taller and try it (it got late last night),so my character head in it all the way also , could be an issue , since my character has hitboxes on all of his parts(head,arms,legs,body,etc……). As well as the normal capsule.

made it taller , but still did same thing. I stepped off at bottom , got back on , and it didn’t move. When I stepped back off and on again , it then went up. Then immediately back down before I could get off(at this point I am just standing right in the middle of the box. not moving or anything)… Then next time I step in it worked perfect. My float it set to -3700 since that is the distance down to the terrain. the timeline track is 0 to 1 and time value at 1 , is 3 seconds, Seems to to travel down and up at a good speed with those settings.

Sometimes when reaching bottom , I start walking to edge of lift and it will take off back up , before I get off the lift. Then it will be stopped at the top. When I am down on the ground. As I fall off the lift.

I have no idea what you’re doing :wink: so here’s a small project with just the lift example in. The code above works just fine…


Thanks , let me check it out.

it opened but gave me an error. I am in 4.20. Let me install 4,23.Or what version are you using?

Ah, sorry, it’s 4.22

ok so how you got that? lift parented to the root? box parented to the scene component? Or it looks like box to scene?scene to lift?

Nope, collision is parented by the lift and that is parented by the scene. The scene is only there because otherwise the lift’s transformation would not be zero. It’s just a way of not having to use GetRelativeBlah when you don’t need to. For more info on that, see:

You’ve gotta have the collision parented by the lift otherwise it doesn’t go up and down with it.

must be something in my project. I set it up just like you have and it works mostly. but sometimes it don’t move when I get on. Once, I had it go back up as I was getting off. I am in third person , but I don’t think that would matter. Just now I stepped on it , but it didn’t move. When I stepped off ,it then went up.